Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

2003 H6 3.0L sudden engine stop no start fuel delivery


  • Please log in to reply
7 replies to this topic

#1 screwbaru2

screwbaru2

    Subaru Nut

  • Members
  • 566 posts
  • hope valley

Posted 01 August 2013 - 12:33 PM

I recently had a fuel delivery issue with my 2003 OB 3.0. We were driving when suddenly the engine quit and wouldn't start.  I was able to isolate it as fuel delivery by spraying a small amount of starting fluid into the intake duct ahead of the air filter.  This allowed the engine to fire and run just long enough to determine that everything was firing.

 

So off to the PC I went to use the most useful diagnostic tool I have: USMB.  A search on H6 3.0 fuel delivery produced no less than 6 of the same issues!  I checked the citied "cap" and sure enough it was cracked and mostly likely leaking not allowing pressure to build up or the chamber to fill.   

 

I ordered a new OME pump installed it today and Voila!  My screwbaru is running!

 

Just wanted to add my issue to the others and thank you all at USMB for a fine and useful site!



#2 1 Lucky Texan

1 Lucky Texan

    I read a lot about Subarus

  • Members
  • 4,661 posts
  • Texas

Posted 01 August 2013 - 01:36 PM

Save your old pump assembly - for about $60, it can be fixed up with a cap for the 04 (which is longer but fits just fine) and an $0.80 o-ring.

#3 njdrsubaru

njdrsubaru

    is this thing on?

  • Members
  • 1,198 posts
  • Old Bridge, NJ

Posted 23 August 2013 - 09:59 AM

just did this fix and it works



#4 Cougar

Cougar

    Elite Master of the Subaru

  • Members
  • 6,340 posts
  • Anchorage

Posted 23 August 2013 - 11:37 AM

I think I remember reading something about this issue. This cracked "cap" that is mentioned, is it located on the fuel pump?



#5 1 Lucky Texan

1 Lucky Texan

    I read a lot about Subarus

  • Members
  • 4,661 posts
  • Texas

Posted 23 August 2013 - 11:51 AM

I think I remember reading something about this issue. This cracked "cap" that is mentioned, is it located on the fuel pump?

 

yep - kinda like;

 

16805d1279845139-2001-subaru-just-shut-d



#6 njdrsubaru

njdrsubaru

    is this thing on?

  • Members
  • 1,198 posts
  • Old Bridge, NJ

Posted 23 August 2013 - 11:54 AM

yup thats the one!



#7 Cougar

Cougar

    Elite Master of the Subaru

  • Members
  • 6,340 posts
  • Anchorage

Posted 23 August 2013 - 12:16 PM

Thanks very much 1LT.



#8 grossgary

grossgary

    Elite Master of the Subaru

  • Members
  • 19,745 posts
  • WV

Posted 24 August 2013 - 05:54 AM

how many miles on the old one, want to sell it?  with 2 H6's i'd love a back up.

 

I

 

I ordered a new OME pump installed it today and Voila!  My screwbaru is running!






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users