Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

EA-EJ swap vacuum-heater controls


  • Please log in to reply
10 replies to this topic

#1 rcrad4

rcrad4

    New User

  • Members
  • PipPipPip
  • 36 posts
  • Centralia, WA

Posted 21 August 2013 - 11:43 PM

hey guys! got my ej22 swap complete and am lovin how she drives!

I am curious as to what everyone has done for getting a good vacuum for the heater controls? I hooked up what i thought might be sufficient but I can't change the control from anything other than the mid dash vents, to say the most important defrost. :wacko:

any input and ideas are greatly appreciated!

thanks in advance,

Ryan



#2 obk25xt

obk25xt

    Subaru Fanatic!

  • Members
  • 534 posts
  • La Center, WA

Posted 21 August 2013 - 11:50 PM

Hook it up to the intake manifold runner! IF, you have everything hooked up properly to the EA system, it should work just fine. The canister in the the lil cubby near the pass side strut tower has a 1-way check valve in it, if you have the in/out hooked up backwards, you won't be getting the vacuum to the HVAC controls properly.....

 

Spencer



#3 rcrad4

rcrad4

    New User

  • Members
  • PipPipPip
  • 36 posts
  • Centralia, WA

Posted 22 August 2013 - 02:55 AM

hhhmmmm ok maybe I have those hooked up backwards. I'll give that a shot.

thanks man



#4 rcrad4

rcrad4

    New User

  • Members
  • PipPipPip
  • 36 posts
  • Centralia, WA

Posted 28 August 2013 - 05:36 PM

alright, so now i've got the line going to the canister behind strut tower coming from a "T" that i put inline with the intake manifold runner. with that line going to #1 on the canister i had the same problem of no movement on interior vents. so I switched it to going to #2 on the canister. now I have movement on the interior vents BUT ONLY when i accelerate...... ?? any ideas on that....
thanks in advance



#5 tractor pole

tractor pole

    [catch phrase here]

  • Members
  • 545 posts
  • Monroe, WA

Posted 28 August 2013 - 05:45 PM

I can take a pic of how mine is hooked up, but you will have to wait until tomorrow.



#6 rcrad4

rcrad4

    New User

  • Members
  • PipPipPip
  • 36 posts
  • Centralia, WA

Posted 28 August 2013 - 05:51 PM

that would be great! thank you!



#7 rcrad4

rcrad4

    New User

  • Members
  • PipPipPip
  • 36 posts
  • Centralia, WA

Posted 30 August 2013 - 10:45 PM

I can take a pic of how mine is hooked up, but you will have to wait until tomorrow.

 get a chance yet?

thank you,
Ryan



#8 tractor pole

tractor pole

    [catch phrase here]

  • Members
  • 545 posts
  • Monroe, WA

Posted 30 August 2013 - 11:08 PM

damn sorry, after that brutal rain we had yesterday I spent this morning and half the afternoon trying to finish the roof on my house. I can take a pic for you in the morning.

 

Ben



#9 rcrad4

rcrad4

    New User

  • Members
  • PipPipPip
  • 36 posts
  • Centralia, WA

Posted 31 August 2013 - 02:12 PM

thats totally understandable man, no worries



#10 tractor pole

tractor pole

    [catch phrase here]

  • Members
  • 545 posts
  • Monroe, WA

Posted 01 September 2013 - 12:28 AM

http://i1154.photobu...zps7f874d2a.jpg
http://i1154.photobu...zps204f1798.jpg
http://i1154.photobu...zps471f6a66.jpg

#11 LPGsuperchargedBrumby

LPGsuperchargedBrumby

    Fully retarded and low on compression

  • Members
  • 654 posts
  • Dunedin, NZ

Posted 02 September 2013 - 03:14 AM

i have mine hooked straight to one of the vac ports on the intake runners with no vacuum accumulator.....it works fine except that i can't change heater while i'm at full throttle....and i normally don't fiddle with the heater when i'm at full throttle anyway so i'm sorted






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users