Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

1980 Brat GL rebuild thread


  • Please log in to reply
45 replies to this topic

#26 Kevint143

Kevint143

    USMB Regular

  • Silver Subscribers
  • 357 posts
  • Bakersfield, CA

Posted 14 March 2014 - 04:20 PM

Found it thanks!



#27 Kevint143

Kevint143

    USMB Regular

  • Silver Subscribers
  • 357 posts
  • Bakersfield, CA

Posted 15 March 2014 - 11:02 AM

So last night I put the EUL headers I built a while back for the Green BRAT on the red BRAT and modified it a bit. it is running 2 inch pipe from block all the way back with two glasspacks. Its so quiet at idle now but has a nice rumble when you get on it! Sorry for the horrible quality video.


Edited by Kevint143, 15 March 2014 - 11:05 AM.


#28 Kevint143

Kevint143

    USMB Regular

  • Silver Subscribers
  • 357 posts
  • Bakersfield, CA

Posted 19 March 2014 - 12:55 PM

 
took the BRAT out for a little drive to do some mountain biking and stopped to snap a pic. 


#29 Kevint143

Kevint143

    USMB Regular

  • Silver Subscribers
  • 357 posts
  • Bakersfield, CA

Posted 25 March 2014 - 02:20 PM

13398227334_f5edf9e920.jpg
Untitled by Kevin Talley, on Flickr

So last night I couldn't sleep and my daughter wanted to hang so I let her stay up late and help me swap the intake manifold from green brat since it had my weber on it and put it on the red brat. In the process I am not confident I hooked my vacuum lines up right. Can someone snap a photo of your weber set up for all the vacuum lines?

Edited by Kevint143, 25 March 2014 - 05:37 PM.


#30 subyrally

subyrally

    Trust your Turbo-Lust

  • Members
  • 2,888 posts
  • frederick, md

Posted 27 March 2014 - 03:43 PM

very cool. i like it in red, that color works nicely on that brat. i think i want a 1st gen when i finish my current brat, lol.



#31 Kevint143

Kevint143

    USMB Regular

  • Silver Subscribers
  • 357 posts
  • Bakersfield, CA

Posted 29 March 2014 - 01:37 PM

So I have been struggling the past few nights. I put the weber on and now I can't get the car to start. I have fuel its getting spark but I think my timing is way off. The car will crank but won't start I have gone through all the processes I can think of to check for fuel and spark and they have all been positive. I can't time it until it starts does anyone have any suggestions?



#32 tundrabrat

tundrabrat

    Eat, Live, Breath Subaru

  • Members
  • 390 posts
  • Anchorage

Posted 29 March 2014 - 05:54 PM

Same thing happened to me. Back to basics1.) set engine to TDC, 2.) align dist gear and shaft and lower into position 3.) confirm rotor is pointing at #1 4.)recheck gaps, 5.) run plug wires. 6.) check coil is hooked up properly (if not replace burnt fuse).

I'll send you a pic of vacuum lines but should just be vac advance and PCV (into filter) other lines are coolant.

Edited by tundrabrat, 29 March 2014 - 05:56 PM.


#33 Scooner

Scooner

    New User

  • Members
  • 378 posts
  • Cheyenne, Wyoming

Posted 29 March 2014 - 07:51 PM

The hood scoop looks really good, i might have to do one on my loyale, non functional of course but it'd look good!

#34 Kevint143

Kevint143

    USMB Regular

  • Silver Subscribers
  • 357 posts
  • Bakersfield, CA

Posted 29 March 2014 - 08:52 PM

That's exactly what I ended up doing tundra and got it started first turn of the key. At tdc I was at #2 on cap/rotor adjusted that and we are good to go! But was test driving it and blew a coolant hose so off to the parts store for a new one!

#35 tundrabrat

tundrabrat

    Eat, Live, Breath Subaru

  • Members
  • 390 posts
  • Anchorage

Posted 29 March 2014 - 10:59 PM

Glad to hear... Just did my shake down run this morning.

#36 Kevint143

Kevint143

    USMB Regular

  • Silver Subscribers
  • 357 posts
  • Bakersfield, CA

Posted 30 March 2014 - 01:07 AM

13503970305_cd64130d3d.jpg
Untitled by Kevin Talley, on Flickr

13504065863_b60ebd205f.jpg
Untitled by Kevin Talley, on Flickr

#37 spicypeanut

spicypeanut

    USMB is life!

  • Members
  • 217 posts
  • LA CA

Posted 30 March 2014 - 01:50 PM

 

So last night I put the EUL headers I built a while back for the Green BRAT on the red BRAT and modified it a bit. it is running 2 inch pipe from block all the way back with two glasspacks. Its so quiet at idle now but has a nice rumble when you get on it! Sorry for the horrible quality video.

This sounds amazing. Got any more info on this custom EUL header you made? If I can get the Brat to sound like my sti, it would make me a happy camper. :)


Edited by spicypeanut, 30 March 2014 - 01:51 PM.


#38 Nico

Nico

    USMB is life!

  • Members
  • 225 posts
  • Hamilton, Ontario, Canada

Posted 30 March 2014 - 10:01 PM

very nice work you have done on that brat it looks perfect ! 



#39 buckkiller

buckkiller

    Advanced Member

  • Members
  • PipPipPip
  • 61 posts
  • yakima wa

Posted 31 March 2014 - 11:39 AM

Man i dig the 1st gens good looking rigs bud....guess ill have to start on one when im done with the 86! :huh:  the biggest problem is finding space for all my rigs lol.

Buck

 



#40 Kevint143

Kevint143

    USMB Regular

  • Silver Subscribers
  • 357 posts
  • Bakersfield, CA

Posted 07 April 2014 - 11:13 PM

13708723295_aea0f739e2.jpg
Untitled by Kevin Talley, on Flickr

Put the wheels off the 79 onto this one because the tires are brand new. Not sure how I feel about the white wheels.

#41 Kevint143

Kevint143

    USMB Regular

  • Silver Subscribers
  • 357 posts
  • Bakersfield, CA

Posted 08 April 2014 - 11:48 AM

 

quick video of the latest exhaust set up. This was a cold start after sitting for two days. I didn't let it warm up because I was just parking it on the street and didn't want to make the garage smell like brat exhaust. I can't stop tweaking with it ha...going to throw something else together soon


Edited by Kevint143, 08 April 2014 - 11:50 AM.


#42 Kevint143

Kevint143

    USMB Regular

  • Silver Subscribers
  • 357 posts
  • Bakersfield, CA

Posted 26 August 2014 - 08:00 PM

Anyone interested in buying this or trading for a wagon of some sort?



#43 tominssti

tominssti

    Newbie

  • Members
  • Pip
  • 6 posts
  • Riga, Latvia

Posted 01 September 2014 - 05:42 AM

Mad ride, I love it. It's sad that there aren't a single one of this model in my country :(



#44 Kevint143

Kevint143

    USMB Regular

  • Silver Subscribers
  • 357 posts
  • Bakersfield, CA

Posted 03 September 2014 - 04:21 PM

Thanks I think I will keep sitting on it for a while. Finish my swap on the 79 and figure out what I want to do with this

 



#45 Kevint143

Kevint143

    USMB Regular

  • Silver Subscribers
  • 357 posts
  • Bakersfield, CA

Posted 03 September 2014 - 04:21 PM

Thanks I think I will keep sitting on it for a while. Finish my swap on the 79 and figure out what I want to do with this

 



#46 Kevint143

Kevint143

    USMB Regular

  • Silver Subscribers
  • 357 posts
  • Bakersfield, CA

Posted 03 September 2014 - 04:22 PM

Thanks I think I will keep sitting on it for a while. Finish my swap on the 79 and figure out what I want to do with this

 






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users