Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Hello USMB, I need help with GL-10 Air Suspension

air suspension gl-10 subaru suspension struts compressor air turbo

  • Please log in to reply
28 replies to this topic

#26 grossgary

grossgary

    Elite Master of the Subaru

  • Members
  • 19,643 posts
  • WV

Posted 27 December 2013 - 12:44 PM

"dead system" - meaning everything is flat and has been non-operational.

 

okay it sounds like it's trying to work as normal then, so computer/wiring should be good.

1.  it starts at start up because the tank is low on pressure

2.  it quits after 10 minutes as designed because the computer shuts it off to prevent overrunning/overheating the compressor

 

It sounds like:
A.  there's a leak - right at the compressor or tank or a really bad leak at the air strut such that all the pressure is bleeding out and not airing up anything

B.  the compressor isn't putting out enough psi to pump anything up

 

You can use soapy water around fittings, orings, connectors, air bags to check for leaks.  the soapy water will bubble where the leak is.



#27 TurboAir

TurboAir

    Member

  • Members
  • PipPip
  • 11 posts
  • Ellensburg, WA

Posted 28 December 2013 - 07:52 PM

Alright guys, I have officially decided that I'm going to convert my car from pneumatic to coil over suspension.  Last night I unhooked the power from all four solenoids, aired up all the bags, drove it to the car wash to clean the engine and the front left bag went flat and as soon as I plugged power to all the bags again and turned on the car, all the air released from the system and I had to drive the car home with no shocks again.

I, like many others i'm sure, simply have too much other spoob to get done both on the car and other things in my life to keep messing with this.

I gave it a good shot so I have no regrets lol

 

Also, we have a parts car that has everything except an engine.  Which means that it everything is compatible, I'll get carpet, interior plastic, rear seats, and coil suspension for free.

 

The parts car is a Loyale, should everything match up?

 

And, are there any sensors or computers that I have to disable/remove in order for the car to behave properly without an air suspension system present?

 

 

 

Oh, and one last question.....does anyone who has experience with the air suspension equipped Subarus know whether or not the car disables the ability to enter 4WD if the car is not jacked up to the proper heighth?  The 4WD would not engage when I first drove the car(haven't tried again since then) and I thought that there might be a chance that's there's nothing wrong with it, it's just the computer disabling it because the car is so low to the ground.      Anyone know?



#28 wagonist

wagonist

    User Awaiting Email Confirmation

  • Members
  • 373 posts
  • Sydney, Australia

Posted 29 December 2013 - 05:15 PM

the 4wd system & the suspension height system are not linked in any way.

 

Which buttons have you got for 4wd?

red(?) one on the gearstick below the lockout button & another "4wd auto" button on the dash? or just on the gearstick?

 

if you have both, which one are you pressing? cos the "4wd auto" button will only put it into 4wd when:

a. the gearbox kicks down a gear

b. the brakes are pressed

c. the wipers are turned on

 

the one on the gearstick puts it directly into 4wd regardless



#29 instigatr

instigatr

    Newbie

  • Members
  • Pip
  • 1 posts
  • Wa, State

Posted 15 January 2014 - 10:28 PM

hi guys

new guy here trying to fix a buddies subaru wgn. he picked up a 88 subaru wgn, 4wd turbo with an automatic. so far i have put a radiator in it after the plastic was so rotten it blew (hopefully the head gaskets survive...), fixed a pretty good oil leak at the front crank seal (PO destroyed a new seal putting it in).

now i am down to the air suspension. the left rear shock boot leaks are badly, right front level sensor in the strut is bad. no problem, i thought. we will just convert it over to regular suspension and then he will not have to deal with the very expensive air shocks failing from subaru. got the front done with used struts from a wrecking yard and though i could replace the entire rear suspension setup with the non-air suspension system. well, that didnt work, mounting system to the body is entirley different. tried some basic air shocks for overload, and like i figured they cant handle the load. has anyone been able to convert them at all? at this point if i could get a good left rear air shock (better if i could get both rear ones) i would be happy. i am just concerned at the age of probably any out there, they would fail relatively soon after replacement.

anyone have any better options?

was reading this thread and someone is asking about conversions, but it never seemed to get answered. sorry if i am hijacking a thread but my problem is at least similar.

thanks for any help.

Aaron







Also tagged with one or more of these keywords: air suspension, gl-10, subaru, suspension, struts, compressor, air, turbo

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users