Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Need help with cigarette lighter socket


  • Please log in to reply
1 reply to this topic

#1 lepetitprince

lepetitprince

    USMB Irregular

  • Members
  • 384 posts
  • Madison Heights

Posted 27 April 2004 - 06:08 PM

Hi, I need help with fixing the cigarette lighter socket. It was working fine untill yesterday( I had my friend's police detector(Valentine One :brow: )) Then this morning, at my friend's house, he figured my front tires are low pressured, so he brought out his electric air pump and plugged into my cigarette lighter socket. It worked for about 7 seconds and then it stopped pumping. I thought there was something wrong with the pump, but I found out that my cigarette lighter socket died. Don't know what exactly happen, maybe burnt the fuse or something. It didnt died fully because if I play around with the police dector and spin around it in the socket, it works. But its pain in the ***** to go through that everytime I need to plug it in.
I really need help fixing this. I'm a novice with car as you can tell, so don't really have an idea of fixing it
Thanks
Dan

#2 RavenTBK

RavenTBK

    Professional Auto Thief

  • Members
  • 661 posts
  • Apalachicola Natl Forest

Posted 27 April 2004 - 06:12 PM

So you're saying it still works when you plug in the fuzz buster, but only if you wiggle the plug?

Drop the dash and it will be painfully obvious on how to pop out the socket. The socket shouldnt be loose in the first place. Should be painfully obvious on what you need to bend/move/turn to tighten it back up. More than likely the housing has spun loose. Drop the dash and tighten it up.

So much pain, so little time. :D




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users