Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Idles fine, runs great at times

Engine tick electronic

  • Please log in to reply
1 reply to this topic

#1 Ace1234765

Ace1234765

    Newbie

  • Members
  • Pip
  • 1 posts
  • Bethpage, TN

Posted 17 December 2013 - 03:28 PM

I have a 1996 Subaru Legacy l sedan, that idles almost perfectly, and drives just as good, but when driving randomly ill hear a small click and the engine will try to die, and after a second or two ill hear another click and it will run just fine, i feel as if this is caused by a loose wire in the ignition system but i need some advice before i take it to a shop



#2 Fairtax4me

Fairtax4me

    Su bah roo'n

  • Gold Subscribers
  • 9,094 posts
  • Charlottesburg, VA

Posted 18 December 2013 - 11:17 PM

Odd for sure. Generally electrical problems will cause the engine to stall or at least make some of the lights in the dash to crazy. Have you checked for stored codes? Does the Check engine light work?
Can you tell a general area where the "click" comes from? Under the dash? Under the hood? Left or right?

I would start by checking the battery cables, and make sure the body ground connection is good.





Also tagged with one or more of these keywords: Engine, tick, electronic

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users