Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Varnished gas in MPFI turbo system problem

ea82t turbo fuel

  • Please log in to reply
3 replies to this topic

#1 BoostedBoxer421

BoostedBoxer421

    Advanced Member

  • Members
  • PipPipPip
  • 33 posts
  • Newport, WA

Posted 31 January 2014 - 11:34 AM

i've recently acquired an 87 RX turbo and it wasnt in running condition. had to get replacement MAF sensor and fuel pump and filter

 

as soon as i tried to get it started i could tell it was trying to fire then all i could smell was varnished gas.. so its been sitting for a while

 

if i pour good gas into throttle body it will fire up for a second, but now that i have good gas in the tank and lines with new filter it doesnt seem to get any gas to the injectors. somewhere between filter and injectors??



#2 rain_man_rich

rain_man_rich

    USMB Regular

  • Members
  • 132 posts
  • Grants Pass

Posted 31 January 2014 - 04:09 PM

Does it get significant gas past the filter?



#3 coxy

coxy

    USMB is life!

  • Members
  • 201 posts
  • Sydney Australia

Posted 01 February 2014 - 06:06 AM

Injectors are likely gummed up with varnish, a good ultrasonic clean needed there I do believe.



#4 BoostedBoxer421

BoostedBoxer421

    Advanced Member

  • Members
  • PipPipPip
  • 33 posts
  • Newport, WA

Posted 02 February 2014 - 08:48 PM

Gets good amount past filter so I'm going to clean all lines past there

ultrasonic cleaning?





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users