Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Ej16


  • Please log in to reply
20 replies to this topic

#1 shapay23

shapay23

    Newbie

  • Members
  • Pip
  • 7 posts
  • St. John's, Antigua

Posted 10 February 2014 - 02:56 PM

Hi i recently bought a subaru impreza ej16 sohc non turbo and i think i have change everything on there such as filters, oil and plugs and plug leads but i still have bad gas mileage and i also notice it has this real slow response when i'm taking off, even when i'm driving and i mash down it hugs back and then takes off like a bat out of hell. What could be the reason for all this to be happening.



#2 Loyale 2.7 Turbo

Loyale 2.7 Turbo

    The Mighty "BumbleBeast"

  • Members
  • 7,278 posts
  • Roatán, Honduras.

Posted 10 February 2014 - 03:39 PM

Welcome!

 

Is your EJ16 Carburated or EFi?



#3 shapay23

shapay23

    Newbie

  • Members
  • Pip
  • 7 posts
  • St. John's, Antigua

Posted 10 February 2014 - 08:24 PM

it's EFI, when i checked online i read that parts of the enigne were curbarated but i doubt it seeing it was manufactured in the year 2000



#4 Loyale 2.7 Turbo

Loyale 2.7 Turbo

    The Mighty "BumbleBeast"

  • Members
  • 7,278 posts
  • Roatán, Honduras.

Posted 10 February 2014 - 09:03 PM

Yes, only the very early EJ15 and EJ16 were Carburated.

 

So, since your EJ16 is EFi and writing about its fuel economy... the bad fuel economy and the slow response that changes to fast response only if you floor the gas pedal, could be done by some different causes; let's start from the Basics:

 

Dirty fuel injectors and something wrong with the Throttle Position Sensor or its Wirings.

 

Kind Regards.



#5 shapay23

shapay23

    Newbie

  • Members
  • Pip
  • 7 posts
  • St. John's, Antigua

Posted 10 February 2014 - 09:16 PM

I've used fuel injector cleaner but still the same action, the throttle position sensor i will have to look at. Thanks.



#6 Fairtax4me

Fairtax4me

    Sooberoo

  • Members
  • 11,871 posts
  • Charlottesburg, VA

Posted 11 February 2014 - 11:47 PM

Is there a knock sensor on the EJ16?
(We never got that engine in the US)

Is there any difference when the engine is cold vs when its warmed up?

#7 shapay23

shapay23

    Newbie

  • Members
  • Pip
  • 7 posts
  • St. John's, Antigua

Posted 13 February 2014 - 08:32 AM

yes there is a knock sensor, actually had to replace it when i first got the car. The car runs well after awhile but hot or cold it still has this hesitant move as i press down from a stand still position or a rolling position.



#8 rverdoold

rverdoold

    Subaru Nut

  • Members
  • 662 posts
  • Netherlands

Posted 14 February 2014 - 08:36 AM

Some questions to fill in!

 

Milage/KM:

Build year:

AT/MT:

2wd/awd:

last valve clearance adjustment:

What oil did you put in (synthetic, and viscosity):

Timing belt: could timing be off? that would be bad. Was it replaced?

 

I have a 1.6 on LPG but also still runs on gasoline. I found this motor very throttle aggressive (not so smooth compared to 2.0 or 2.5). The fuel efficiency is not that good due to the low motor output, unless you do not increase over 3,000 rpm



#9 shapay23

shapay23

    Newbie

  • Members
  • Pip
  • 7 posts
  • St. John's, Antigua

Posted 18 February 2014 - 02:25 PM

milage: 221797km

year: 2000

AT

2wd

last valve clearance adjustment I really don't know

I use 10/30 shell oil

i have never check the timing belt or changed it.


Edited by shapay23, 18 February 2014 - 02:25 PM.


#10 Loyale 2.7 Turbo

Loyale 2.7 Turbo

    The Mighty "BumbleBeast"

  • Members
  • 7,278 posts
  • Roatán, Honduras.

Posted 18 February 2014 - 03:46 PM

...i have never check the timing belt or changed it.

 
 
Well, after fourteen years and 221K kilometers ... :eek: ... that timing belt could be about to snap in no time, maybe already has jumped a couple of teeth... it happened to my Subie some years ago, the Timing belt was so old that had some missing teeth.
 
I Kindly suggest you to check that Timing Belt / Replace Timing kit as soon as possible.
 
Kind Regards.



#11 luko

luko

    Advanced Member

  • Members
  • PipPipPip
  • 121 posts
  • Wayne, NY AKA Upstate NY

Posted 18 February 2014 - 05:22 PM

O2 sensor as well...could be giving your PCM false readings...or you could have a dirty MAF 



#12 shapay23

shapay23

    Newbie

  • Members
  • Pip
  • 7 posts
  • St. John's, Antigua

Posted 19 February 2014 - 08:36 AM

Ok will do.



#13 rverdoold

rverdoold

    Subaru Nut

  • Members
  • 662 posts
  • Netherlands

Posted 19 February 2014 - 02:21 PM

O2 sensor as well...could be giving your PCM false readings...or you could have a dirty MAF 

 

I am not sure my 99 EJ16 has a MAF, i think it is calculated from intake air temperature and atmospheric pressure. Note that the ej16 is the most basic model you could get.

I would for sure check the timing belt it should have been done at 100k and 200k, valve adjustments are every 60k (all KM) as far as i remember.



#14 Loyale 2.7 Turbo

Loyale 2.7 Turbo

    The Mighty "BumbleBeast"

  • Members
  • 7,278 posts
  • Roatán, Honduras.

Posted 19 February 2014 - 06:35 PM

...Note that the ej16 is the most basic model you could get...

 

It depends on the Market, the very basic impreza came here with EJ15.

 

Kind Regards.



#15 rverdoold

rverdoold

    Subaru Nut

  • Members
  • 662 posts
  • Netherlands

Posted 20 February 2014 - 05:26 PM

It depends on the Market, the very basic impreza came here with EJ15.

 

Kind Regards.

Did the ej15 not replace the ej16, in Europe it did

1995 to 2005 = ej161

2004 to now = ej15

20013 to now is ej16 (new one) with CVT in impreza



#16 Loyale 2.7 Turbo

Loyale 2.7 Turbo

    The Mighty "BumbleBeast"

  • Members
  • 7,278 posts
  • Roatán, Honduras.

Posted 20 February 2014 - 07:21 PM

Sorry for the Thread Hijack...

 

The LADM (Latin American Domestic Market) had the 1.5L EJ15 engined impreza in the very basic model: Manual transmission, no 4wd nor power windows nor power locks... while the 1.6L EJ16 engine came with the same basic impreza, but with Automatic transmission.  Seems like the 2000 impreza from the original poster is 2WD automatic EJ16, like the LADM Specs imprezas, see:

 

milage: 221797km

year: 2000

AT

2wd

last valve clearance adjustment I really don't know

I use 10/30 shell oil

i have never check the timing belt or changed it.

 

End of thread Hijack...

 

Kind Regards.



#17 wtdash

wtdash

    Subaru Nut

  • Members
  • 1,151 posts
  • N. ID

Posted 21 February 2014 - 11:08 PM

Hi,

 

Did you replace the fuel filter as part of your filter maintenance? Also, does it rev freely  in Neutral/Park?

 

GL,

TD

 

Off-topic but I can't imagine..

...does this come w/extra passengers - to get out and push up hills??? 

 Makes ~114HP and ~111 ft-lbs (slightly more than the old US EJ18) and it weighs ~3K lbs. 0-100 km = 12.6 secs. AWD/11.8 - FWD, BUT it gets combined 38+ MPG!



#18 rverdoold

rverdoold

    Subaru Nut

  • Members
  • 662 posts
  • Netherlands

Posted 22 February 2014 - 05:52 AM

The old ej16 is big fun in the alps, have to rev constantly to >3500 rpm to get up the 'hill'.



#19 forester2002s

forester2002s

    Subaru Fanatic!

  • Members
  • 698 posts
  • Vancouver Canada

Posted 22 February 2014 - 06:22 AM

Have you tried higher-octane fuel? Perhaps the knock-sensor is doing its job.



#20 Loyale 2.7 Turbo

Loyale 2.7 Turbo

    The Mighty "BumbleBeast"

  • Members
  • 7,278 posts
  • Roatán, Honduras.

Posted 22 February 2014 - 10:35 AM

The old ej16 is big fun in the alps, have to rev constantly to >3500 rpm to get up the 'hill'.

 

Just like our Old-School EA82 Subies ... :D ...



#21 shapay23

shapay23

    Newbie

  • Members
  • Pip
  • 7 posts
  • St. John's, Antigua

Posted 03 March 2014 - 10:13 AM

Well it doesn't have a o2 sensor neither the hole for it but it does have the connection....I changed everything. I realize thou that the transmission shifts 1st and 2nd reasonably well but third has the slow build up; I was wonder if its because its not turbo charge and also a single cam why it reacts this way. Seems like it doesn't shift out of third when i slow down so when i accelerate i get the sluggish movement.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users