Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

1997 Legacy GT replacement coils do not fit.

ignition coils fitment GT Legacy 1997 Diamond transition misfire

  • Please log in to reply
2 replies to this topic

#1 RedGTLegacy

RedGTLegacy

    Newbie

  • Members
  • Pip
  • 2 posts
  • North Saanich BC

Posted 14 March 2014 - 12:30 PM

Car Information: 1997 Subaru Legacy GT Sedan, 2.5L DOHC

 

Hi there, 

 

Im hoping that someone may be able to tell me why the ignition coils I had delivered for my car are not the correct ones, I've searched and searched and every coil-pack I come across is depicted as the ones I received. However the stock pack I'm attempting to replace Is a much smaller pack:

 

Diamond F-560.

 

The new pack will not bolt and does not possess the same connecting pin. My engine has not been swapped, I know it is a 2.5L EJ25 as I had the timing belt done about a year ago.

 

I've been reading that my year was a "transition" year and that I may have a certain type of pack. Does anyone know about this? I'm really looking forward to continuing my troubleshooting for a misfire and I was hoping this might have been the fix.

 

Thanks in advance for the time!



#2 natetru

natetru

    Member

  • Members
  • PipPip
  • 23 posts
  • orestes, indiana

Posted 14 March 2014 - 01:38 PM

i also have a 97, built in October....recently did headgaskets. the valve cover seals were incorrect and after going thru some hoops found I had valve covers from a pre transition motor....so, look up the part for a 96 and see if the pic matches whats on your vehicle



#3 RedGTLegacy

RedGTLegacy

    Newbie

  • Members
  • Pip
  • 2 posts
  • North Saanich BC

Posted 14 March 2014 - 01:57 PM

Thanks! I appreciate it, hopefully have this resolved sooner than later!







Also tagged with one or more of these keywords: ignition, coils, fitment, GT, Legacy, 1997, Diamond, transition, misfire

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users