Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

98 subaru legacy issues


  • Please log in to reply
3 replies to this topic

#1 triiifashions

triiifashions

    USMB Regular

  • Members
  • PipPipPip
  • 37 posts
  • del rio

Posted 11 May 2014 - 10:32 AM

I have a 98 subaru legacy sus limited and have a few issues my main one right now is it strugglin starting. Seems to take longer than it should and sometimes sputters before starting.also sometimes when starting there is a loud thump under gear shift between the seats from under the car??? Thump happens right as car is starting and it sputters a bit then a thump or two and then fine!!!

#2 Fairtax4me

Fairtax4me

    Su bah roo'n

  • Gold Subscribers
  • 8,529 posts
  • Charlottesburg, VA

Posted 11 May 2014 - 10:48 AM

Clunk or thump under the car could be a worn out or broken transmission mount. Could also be the exhaust hitting the bottom of the car which would be because of a bent pipe or broken exhaust hanger.

Way too many things that can cause hard starting.
How many miles are on the car?
When was the last time it had a tune-up?

#3 triiifashions

triiifashions

    USMB Regular

  • Members
  • PipPipPip
  • 37 posts
  • del rio

Posted 11 May 2014 - 02:17 PM

Just had cam seals and timing belt....around 160 000 i think

#4 Fairtax4me

Fairtax4me

    Su bah roo'n

  • Gold Subscribers
  • 8,529 posts
  • Charlottesburg, VA

Posted 12 May 2014 - 10:11 PM

What about plugs, wires, air and fuel filters, PCV valve?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users