Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

1984 gl wagon turn signal problems


  • Please log in to reply
2 replies to this topic

#1 Gwywnc

Gwywnc

    Advanced Member

  • Members
  • PipPipPip
  • 54 posts
  • Cherokee nc

Posted 20 June 2014 - 12:18 AM

Had to drop the steering assembly and unplugged a lot of stuff but it all seems to only plug in one way. So I got everything plugged back up that I can see that goes together and every thing works but the turn signals. Can some one give some advice

#2 Crazyeights

Crazyeights

    Crazyeights

  • Gold Subscribers
  • 1,008 posts
  • Pacific Northwest

Posted 20 June 2014 - 12:21 AM

Turn signal relay unplugged or miss-plugged near the steering column under the dash  I doesn't look like a regular flasher, it looks like a relay as I recall. Good Luck!



#3 Gwywnc

Gwywnc

    Advanced Member

  • Members
  • PipPipPip
  • 54 posts
  • Cherokee nc

Posted 20 June 2014 - 10:23 AM

I looked and nothing seems to be mis-plugged. I think I found the flasher relay cause when I turn the turn signal in these two round "things" under the dash gets warm/hot. I cannot figure it out...




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users