Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Interior lighting doesn't work (dash, radio), nor does heater

brat 1987 interior radio electrical

  • Please log in to reply
2 replies to this topic

#1 comatosellama

comatosellama

    Advanced Member

  • Members
  • PipPipPip
  • 87 posts
  • Ann Arbor MI

Posted 14 August 2014 - 11:02 PM

So the title pretty much says it all, can't get my brat's interior lighting to work besides the dome. Would very much like to have that, what are the main wires for that? Also, my heating doesn't work, but I don't have my ac compressor connected, don't know if that's the problem or not. Anything helps

Thanks



#2 MilesFox

MilesFox

    Catch this Fox!

  • Members
  • 10,665 posts
  • Madison/Milwaukee, WI

Posted 15 August 2014 - 08:32 AM

Check the fusuble links under the hood in the little black box by the battery cable. There should be 4 links, 1 black (main) and 2 green, and a red. see if one is broken or missing. A modern 'J-fuse' can be substituted as a replacement



#3 comatosellama

comatosellama

    Advanced Member

  • Members
  • PipPipPip
  • 87 posts
  • Ann Arbor MI

Posted 15 August 2014 - 08:00 PM

Previous owner hacked the wiring harness so shreds. Ended up unplugging something and it worked.







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users