Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

92 loyale a/c compressor always runs

hvac ac heater defrost

  • Please log in to reply
3 replies to this topic

#1 cyama167

cyama167

    Newbie

  • Members
  • Pip
  • 5 posts
  • reno

Posted 07 January 2017 - 11:21 PM

I'm working on a 92 loyale 4wd wagon AT and AC.  When I select anything on the panel the AC compressor runs and cycles on and off while its running down the road. I can tell because it pulls on the engine when the compressor engages.  I have seen defrost cycles run the AC compressor on some cars, but not the heater. Is this designed into these cars?  This is the 2nd panel I have changed on the car because the vacuum valves inside the panel dried up, but both have acted the same way with respect to the AC running. Any suggestions or help is appreciated! 

 



#2 DaveT

DaveT

    Subaru Nut

  • Members
  • 3,820 posts
  • Colchester

Posted 08 January 2017 - 12:20 AM

Compressor cycling is normal.  BUT  It should only run in defrost and AC modes.  It should not run in any other mode.

Having a FSM schematic should help you.

 

I think the switch that actuates the electric part of controlling the compressor is a micro switch that is mounted on the heater box.  It gets activated by linkage moved by the vacuum motors when AC OR defrost is selected.



#3 cyama167

cyama167

    Newbie

  • Members
  • Pip
  • 5 posts
  • reno

Posted 20 January 2017 - 10:40 PM

Thanks Dave! Where can I find the FSM schematic?  Do you know if this micro switch failure is a common problem? I was lucky enough to get into 4 or 5 loyales at the local pick and pull last month, so I can take additional parts if necessary.



#4 DaveT

DaveT

    Subaru Nut

  • Members
  • 3,820 posts
  • Colchester

Posted 21 January 2017 - 10:36 AM

There might be a link for the schematics somewhere on the forum. Or maybe the whole manual? Am am not sure, since I've had them since I bought my first GL.

I have not seen this as a common failure, or read about it here often, if ever.





Also tagged with one or more of these keywords: hvac, ac, heater, defrost

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users