Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

I'm back, an apology, and stuff...


  • Please log in to reply
7 replies to this topic

#1 oobnuker

oobnuker

    Subaru Nut

  • Members
  • 522 posts
  • Oxford, CT

Posted 15 June 2004 - 11:38 AM

I'm back. Not sure if anyone remembers me, or if this is the right place to post this. Anyway, after throwing the timing belt on my Loyale for a second time (naked belts, lots of oil leakage, blah blah = thrown belts), and constant hatred from my wife over my ugly rump roast car ('90 Loyale Wagon), we bought a '99 Dodge Neon R/T coupe. It was a nice car, mint, got a great deal on it. Long story short, I wrecked the car last Friday and am lucky to be alive.

I owe some people out there some bumper stickers, and I owe someone on the West Coast an Oil Separator. I have no excuses for having not sent the stuff out in like 9 months - just life got weird on me, and blah blah blah. So I am here to make good on those deals.

My Loyale sat for 5 months with no love. Housed quite a few bee hives, sheltered local cats from the rain, but it didn't get any uglier. I was bored one day - my wife was out, I had my two youngest boys with me and decided we were going to get that bad boy running. Ran out and got a new timing belt and went to work. I cracked off the remaining brittle timing covers, cleaned up the engine as best as I could and started putting it all back together. I drilled a hole in the bellhousing (thanks Moosens for the tip a long long time ago) to stop the crank from turning. Got her all lined up, got the belts on, and pulled my van up for a quick jump start. The beast fired right up. After sitting for months she turned over and coughed up all that neglect and abuse and spit it out the tailpipe ("underpipe", the exhaust was broken off at the end of the Y-pipe).

The boys were happy and I was happier. I took it out onto the road and gave it a few quick jabs with the brakes to grind the rust off and make sure the old bastard stopped. Piled the boys in and took it for a drive. We flew down the backroads at 60 and did a few 4-wheels-off jumps, grinning ear to ear. Took her down the dirt/rock access roads for the powerlines. When we got home, I parked it on top of an 8' high woodchip pile - dug in to the axle nuts... :D Needless to say, my wife was like "WTF!?!?!"

This was all a couple of weeks ago - fast forward to last friday, and it's a good damned thing I got it all back together. I spent about 3 hours yesterday getting it all straightened out. Set the timing, changed the oil, cleaned it up some more. I put a super-ghetto exhaust on: y-pipe stub -> 2" pipe -> 2" Thrush Glass Pack -> side exit by the B-Pillar :D sounds sweet.

So this has dragged on long enough. Not here for attention or anything really, just wanted to sort things out with the guys that I ...ahem...am a little late in shipping stuff to.

Mods feel free to move this to where ever it should go, but I hope that the relevant parties find this so I can get their infos again and get the stuff sent out.

Edit: Forgot to apologize. A big apology to anyone who has waited this long for me to ship stuff out. My Neon let me down (didn't stand up well against the jersey barrier, my Loyale has left me on the side of the road a couple of times, but the guys on this board have always been helpful - and I thank you.

#2 Russ Hill

Russ Hill

    Jesus Freak

  • Members
  • 520 posts
  • VANCOUVER,WASHINGTON

Posted 15 June 2004 - 03:19 PM

I had the oil separator, Thanks for coming back.

All is forgiven..
Contact me and I'll re-send my address.

#3 calebz

calebz

    Andys Coupe killed my cat

  • Administrator
  • 7,547 posts
  • Tacoma

Posted 15 June 2004 - 04:28 PM

Welcome back.. you're in good company

#4 moosens

moosens

    Psychotic Subathusiast

  • Members
  • 1,308 posts
  • Bridgeport CT

Posted 15 June 2004 - 05:39 PM

:drunk:
yo!!!!!

#5 viceversa

viceversa

    Subaru Fanatic!

  • Members
  • 368 posts
  • Virginia

Posted 15 June 2004 - 07:54 PM

That's one reason to drive disposable cars, I have 92 loyale wagon. Wreck it - no big deal. But a 99 model?

Glad to see that no flying body parts were involved. After all, _that's_ the important thing.

#6 oobnuker

oobnuker

    Subaru Nut

  • Members
  • 522 posts
  • Oxford, CT

Posted 16 June 2004 - 05:58 AM

I had the oil separator, Thanks for coming back.

All is forgiven..
Contact me and I'll re-send my address.


Sent you an email through the board - let me know if it gets there.

#7 oobnuker

oobnuker

    Subaru Nut

  • Members
  • 522 posts
  • Oxford, CT

Posted 16 June 2004 - 06:00 AM

To everyone, thanks.

As an added bonus, and to jog everyone's memory, here are some pics of my car: http://bankruptsoul....ils.php?album=5

#8 moosens

moosens

    Psychotic Subathusiast

  • Members
  • 1,308 posts
  • Bridgeport CT

Posted 16 June 2004 - 04:21 PM

edit-sorry but my keyboard goes whacky on me sometimes.
Art,calll me sometime.Was wondering about all those parts you had.I emailed you through eBay but never heard from you.

Phone number is the same.Email if you need it again.Glad to see you rockin and rollin.I knew those powerlines would make for some fun sometime.So,can I come up and play?:)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users