Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

87 Nissanbahrd body starts but wont stay running


  • Please log in to reply
3 replies to this topic

#1 ClassySoob

ClassySoob

    Advanced Member

  • Members
  • PipPipPip
  • 86 posts
  • McCammon, ID

Posted 10 May 2017 - 12:27 AM

So I have this 87 Nissan hard body that sat through winter. Before it ran just fine, now not so much. When I first tried to mess with it, it wouldn't start up at all with out the help of starter fluid. After a bit of playing with it and spray in carb cleaner through some of the hoses sand jets, it start up, idle smooth for a couple seconds then dies out. When I try to give it gas, it'll kill it faster. It'll run while spraying fluid into the carb, but wont on its own. Anyone know what's up, or how to fix it?

#2 ClassySoob

ClassySoob

    Advanced Member

  • Members
  • PipPipPip
  • 86 posts
  • McCammon, ID

Posted 10 May 2017 - 12:30 AM

Oh and it has the 2.4L Z24i engine with electro injection

#3 matt167

matt167

    Certified Subaru Nut

  • Members
  • 872 posts
  • Prattsville Ny

Posted 18 May 2017 - 11:59 AM

dead fuel pump



#4 ClassySoob

ClassySoob

    Advanced Member

  • Members
  • PipPipPip
  • 86 posts
  • McCammon, ID

Posted 18 May 2017 - 06:58 PM

I figured it out, the feul pump was working fine.looked under the dash and found a disconnected wire that went to the injectors.started right up.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users