Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Duty C solenoid issue - replaced - wiring issue?


  • Please log in to reply
13 replies to this topic

#1 monkeyposeur

monkeyposeur

    New User

  • Members
  • PipPip
  • 22 posts
  • Salt Lake City

Posted 19 August 2017 - 11:30 PM

Car: USDM 93 SS Turbo Legacy 4EAT

 

I had the 16 flashes, did the handshake and code indicated Duty C solenoid issue. I have slight torque bind at slow turns, with FWD fuse in place torque bind still occurs. 

 

I replaced the duty C solenoid and the flashes persist and the torque bind is still there. While everything was apart I replaced the clutch drum with a lower mileage drum and did some sanding of the clutch plate grooves.

 

While separating the tail housing I pulled the housing out too far and pulled the wiring out of the pin to the duty C harness plug. I soldered on new connector. I installed the new duty C solenoid and applied sealant to the housing and started to put everything back together. I realized that I soldered the wrong end of the duty C harness plug so I had two identical ends!!! To save time I cut both harness plugs and just soldered them together and bolted the tailhousing back on.

 

The next day the torque bind seemed to go away, but the flashes persisted. The next day the torque bind came back. I don't know if my solder job was bad (not likely, i solder RC helicopter wires all the time with success), I pinched the wiring when I put the tailhousing back on, or messed up something when I pulled the pin off.

 

Anyway I  started doing some diagnostics and am kinda stumped at this point.

 

I checked the resistance of the duty c solenoid and it is 24 ohms which is way out of the 1 ohm max range given in the FSM. The flow chart says to replace the duty C solenoid ground.

Does anyone know how to replace this ground?

EDIT: Here is some more info.

Links to FSM diagnostic procedure 
http://www.main.expe....id_c_diag1.jpg
http://www.main.expe....id_c_diag2.jpg

To check the Duty C solenoid's ground disconnect connector from the transmission, and measure the resistance oftransmission connector receptacle and transmission case. I put the probe on pin 4 and the trans case and got a reading of about 28 ohms. The max allowed is 1 ohm so the reading I got would indicate a bad duty C solenoid Ground.

If you look at the pin out diagram you can see that the duty C ground is spliced into the signal wire going to the duty C. This is the line that I had to cut and splice. 

The FSM flowchart states that if the ground line is out of the 1 ohm spec to repair the ground line. Unfortunately I don't have the transmission section of the first gen FSM. So in my mind the only way that I could replace the original ground would be to drop the trans, take it apart, and replace the internal wiring. Not an easy task. 

However, in theory shouldn't i just be able to run a new ground wire from pin 4 to the chassis? It wouldn't be in a loop like the original wiring but that should provide a good ground for the TCU and should in theory provide a low resistance value?

If one looks at the wiring going into the 4EAT pin 4 ground loops into the duty C signal wire, so shouldn't running a new ground by tapping into the wire coming out of pin 4 work?:

wol_error.gif This image has been resized. Click this bar to view the full image. The original image is sized 3264x2448.

AY6JuxJ.jpg?1

My other idea is to go and measure the resistance of the donor legacy at the junkyard and see if pin 4 of the donor car gives a low resistance measurement. If I get a high number then I know that something else is the issue.

When I follow the FSM procedure to measure the resistance of the duty C solenoid itself (pin 4 and 11 of the connector) I get nothing, which would make sense if I am not getting a ground.

 

Or is the ground going to the duty C inside the trans not your typical ground and one of the 'powered' grounds you find in a Subaru? I am also going to cut open the wiring loom going and see if the ground has a broken connection.


So perhaps the duty C solenoid was fine all along and I just have a wiring issue. If anyone has any ideas please let me know. I'll post back any findings I get as well.


Edited by monkeyposeur, 22 August 2017 - 10:47 PM.


#2 gregsplett

gregsplett

    Newbie

  • Members
  • Pip
  • 3 posts
  • olympics

Posted 20 August 2017 - 08:46 AM

I am not going to offer any advice as I have not yet even laid eyes on the duty c but I can offer this link to the full 1992 service manuals.

 

https://sl-i.net/FOR...ervice-Manuals-(FSM)-Every-Model-USDM-EU



#3 monkeyposeur

monkeyposeur

    New User

  • Members
  • PipPip
  • 22 posts
  • Salt Lake City

Posted 20 August 2017 - 10:23 AM

Thanks for the link. Unfortunately the FSM contained in the link does not contain the transmission control system section that I need. :(



#4 Gloyale

Gloyale

    It's a sickness

  • Members
  • 10,409 posts
  • Corvallis, OR PNW

Posted 20 August 2017 - 12:20 PM

solenoid and the TCU ground through a bolt inside the trans.  one of the valve body bolts IIRC.

 

I would check the ground wire from trans to body at top of the trans.  One would think being bolted to the engine is enoguh, but I've seen weird issue with things not working well without a direct ground for the trans.

 

If anything, tie the pin 4 wire (still connected to both TCU and Duty C) to the body ground....but don't cut just add "t"



#5 monkeyposeur

monkeyposeur

    New User

  • Members
  • PipPip
  • 22 posts
  • Salt Lake City

Posted 20 August 2017 - 10:12 PM

I have been asking about this issue on NASIOC and there is some good information about the wiring schematic: https://forums.nasio...27#post45292427


I went out and did some more testing. I tested pin 4, same result as before. I tested pin 11. Nothing registered. I tested pin 4 & 11 again, and still nothing registered. Looking at the wiring diagram again I realized that the pinout of the transmission connector looked more like the female end that goes to the TCU. Was I reading it backwards??? Apparently yes! derp.gif

I checked the correct position of pin 4 and got .3 ohms! So the ground line is within the 1 ohm range. I then checked pin 4 & 11 and got 13.6 ohms, which is within the 9-15 ohm range! smile.gif So the ground line is good, and so is the solenoid! If I followed the FSM flow chart I would have checked the TCU output signal first, but I figured it was easier to check the ground and solenoid first. 

According to the flow chart the TCU must be faulty. I'll pull the junkyard TCU tomorrow and see if it solves the problem. I'll probably check the output voltage of the current TCU and see what I get.

 

Maybe the original duty C solenoid was good all along, or went bad and helped fry the TCU? I'll be able to answer the TCU question in a day or two. I hope it all works!!!

At least I'm learning something.



#6 monkeyposeur

monkeyposeur

    New User

  • Members
  • PipPip
  • 22 posts
  • Salt Lake City

Posted 21 August 2017 - 11:31 PM

Update:
 
After work I went to the junkyard to pull a TCU. The 93 Legacy w/90k I have been salvaging was gone.  I was going to pull the moonroof assembly and motorized seatbelt assemblies and stash them away. 
 
From what I have read the 90-92 TCUs have different wiring than the 93-94s but I'm not 100% sure on that. Anyway I pulled a TCU from a 93 sedan with 4WD and then pulled a TCU from a sedan with FWD. They are different TCUs with different part numbers and the 4WD TCU is stamped 4WD and has the designation 'KY' in large letters.
 
 
 
There are differences between the NA and Turbo TCUs although they can be interchanged. At first I assumed they would be the same but I poked around on bbslegacycentral before I installed the NA TCU. The main difference that was reported is that the NA TCU will go all the way to redline and bounce off the rev limiter at 7k, and exhibits different shift patterns and sometimes a rev hang.
 
I had yet to check the TCU output voltage of the turbo ECU and I wanted to know how it functioned so I swapped it in. It takes about 10 minutes at the most. Remove kick panel and remove the two bolts that hold the TCU in place and swap in the new one. The TCU is a gold box so it's hard to miss, it's left of the steering column.
 
Started the car and the 16 flashes were gone!  Time for a test drive. I backed out of the driveway and did a tight slow turn and no more torque bind! 
 
Did some WOT pulls and it would sometimes go all the way to 7k in first gear. bounce off the rev limiter a bit and then shift. Not too big of a deal. I then switched to POWER mode and it would do the same thing. It wouldn't always rev to 7k though, but almost always if you just mashed the pedal and ran it out. I could get it to rev almost to 7k, blip the gas and get it to shift so it could be worked around if you are paying attention. Felt pretty good to run it to 7k for the first time, lol. 
 
After the test drive I tried to measure the output voltage from the turbo TCU and NA TCU but I was using my multimeter wrong. I think I know what I was doing wrong so I'll test it in the next day or two. 
 
So in the meantime the NA TCU is going to be a great fix. I am asking around for a turbo TCU so I should be able to find one sometime soon to swap back in.
 
I then took apart the turbo TCU to see if there was anything visually wrong with the circuit board. 
 
   
 
 
I've done a bit of soldering and repair with RC helicopter boards so I kinda know if something looks wrong. Visually the board looked fine. No loose bits or burn marks. I'm going to do some research and figure out if there is any way I can diagnose and repair the TCU.
 
Once I measure the TCU outputs and resistance of the wiring harness I will post what I get.
 
I think that the original TCU was probably on it's last legs and since the Duty C solenoid is activating all the time that wears out the TCU components. And perhaps the solenoid actually went bad that taxed the components even further. I swear the duty C solenoid was working for the test drive after I installed it so maybe then the TCU just crapped out. Just a wild theory but I'd like to think that all that work wasn't for nothing.  I guess we'll see how this plays out.


#7 CNY_Dave

CNY_Dave

    03 LL Bean H6

  • Members
  • 1,882 posts
  • Near Cortland NY

Posted 22 August 2017 - 12:06 PM

I had read, ages ago, about one flavor of TCU where the output transistors would go bad.

Probably one of the ones Q520 - Q524 in that pic.

Connector pinout should get you enough info to figure out which one it is.



#8 monkeyposeur

monkeyposeur

    New User

  • Members
  • PipPip
  • 22 posts
  • Salt Lake City

Posted 22 August 2017 - 10:51 PM

Thank you CNY_Dave. I found the thread you might be referring to: http://www.ultimates...-to-bad-duty-c/

 

I have more evidence that the TCU may be bad. I measured the voltage output of the TCU with the FWD fuse in and the accelerator pedal released and it was 11.9 V. This is in the specified voltage range of 8-14 V. The NA TCU output voltage is 11.4 V. However the output of the TCU with the FWD fuse removed and the pedal depressed is 10.2 V. The specified range is 0.5 V max. What is strange is the output of the TCU under the same measuring condition is 4.8 V. So both TCUs are out of range, but the Turbo TCU is a lot farther out of the range. 
 
My board shows no signs of damage like the board in the link above. I checked each of the transistors paying special attention to the transistor that is connected to pin 3, the duty C solenoid pin. They all read the same! So so far I have no indications that the transistor for pin 3 is in any way falty. The resistors measure in spec and I was able to follow the circuit all the way to one of the tiny black thingys on the back side. The black thingy looks like a small fet but I am not sure what kind of component it is.
 
I found a local electronics repair guy and with some persuasion I might be able to get him to repair the board if it needs it, or at the very least diagnose the issue. He feels working on older TCUs is potentially dangerous and I can see why for liability reasons. 
 
I am also trying to figure out what JDM 20G transmissions may be compatible with the SS. There isn't a lot of information on them and I haven't come across any JDM wiring diagrams with which to compare to the SS 4EAT wiring. I am considering buying a complete 93ish JDM 20G 4EAT drivetrain and swapping that in next summer just to freshen things up. Although I would rather do a 02-03 WRX harness merge and build another 205/22T hybrid to modernize things a bit.
 
Once I know more I'll update. But so far the NA TCU is working nicely so that's a success. Still looking for a replacement Turbo TCU. If anyone has a 93-94 4EAT Turbo Legacy TCU send me a PM.

Edited by monkeyposeur, 22 August 2017 - 10:51 PM.


#9 CNY_Dave

CNY_Dave

    03 LL Bean H6

  • Members
  • 1,882 posts
  • Near Cortland NY

Posted 23 August 2017 - 11:16 AM

Did you measure the voltage with the solenoid connected or disconnected?

If connected, if the solenoid (or circuit to it) has too much or little resistance that would throw the voltages off.



#10 monkeyposeur

monkeyposeur

    New User

  • Members
  • PipPip
  • 22 posts
  • Salt Lake City

Posted 22 October 2017 - 10:58 PM

I measured the voltage with the solenoid connected. Since the solenoid is only accessible if you remove the tail housing I don't see how it would be practical to remove the tail housing to test the solenoid. The FSM protocol doesn't specify to remove the solenoid before measuring. 



#11 CNY_Dave

CNY_Dave

    03 LL Bean H6

  • Members
  • 1,882 posts
  • Near Cortland NY

Posted 23 October 2017 - 03:02 PM

The wire can be isolated, cut, and then spliced after testing.



#12 monkeyposeur

monkeyposeur

    New User

  • Members
  • PipPip
  • 22 posts
  • Salt Lake City

Posted 25 October 2017 - 09:52 PM

Hmm, I'm not quite sure I am understanding what you are saying. Are you saying to cut the solenoid wiring going into the transmission. measure the resistance of the wire, and then splice it back together?



#13 CNY_Dave

CNY_Dave

    03 LL Bean H6

  • Members
  • 1,882 posts
  • Near Cortland NY

Posted 26 October 2017 - 12:14 PM

Well, I'm quick to cut and splice, not really all that helpful maybe. You could cut the wire to the solenoid, under the dash would best, and measure the voltage without the solenoid.

But the rest of the wiring wouldn't raise what the TCU was putting out unless it had a partial short to +12V.

 

You know, unless the solenoid is mostly open, maybe the TCU output disconnected can drift high unless connected by some resistance to ground.

Yo check for that you can pull the connector at the TCU or behind the intake and measure the solenoid ohms to ground thru the connector.



#14 Gloyale

Gloyale

    It's a sickness

  • Members
  • 10,409 posts
  • Corvallis, OR PNW

Posted 26 October 2017 - 12:45 PM

The wire can be isolated, cut, and then spliced after testing.

 

Better way is to pull that one pin from the intermediate connection at the trans.  Reinsert after testing.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users