Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

08 Outback: Can't pull DTCs


  • Please log in to reply
6 replies to this topic

#1 john in KY

john in KY

    1000+ Super USER!

  • Members
  • 1,607 posts
  • KY

Posted 24 November 2017 - 11:46 AM

Car flashed a bunch of icons returning home from dinner last night.  CEL/cruise/the letter "S"/some icon that looks like a car with 2 squiggly lines.  Used a code reader this morning and the reader gets me as far has "Err" which I assume is error.  

 

Checked the same reader in my 95 and it worked as designed. 

 

What am I doing wrong or do I need a newer code reader. the one I have is at least 10 years old.  

 

Back to the 08.  Went to change the shift mode (car has 3 different settings) and no-go.  Remained in the "sport" mode.   

 



#2 john in KY

john in KY

    1000+ Super USER!

  • Members
  • 1,607 posts
  • KY

Posted 24 November 2017 - 03:45 PM

Went to AutoZone. #6 coil. Pulled battery. Lights out. Anyone recommend a good scan tool?



#3 wtdash

wtdash

    Subaru Nut

  • Members
  • 1,541 posts
  • N. ID

Posted 24 November 2017 - 03:54 PM

the 'squiggly' lines is usually traction control - Owner's Manual will confirm.

 

That generally does indicate an issue w/the Transmission-side. Simple 'CEL'  code readers would not likely read those anyway.

 

2008 is probably CANBUS...although I thought the OBD2 scanners still worked....may b not so much?

 

Search online for a CAN BUS reader or see if you can find the manual for yours to verify.

 

No sure  about 'what' would cause your issue....

 

Did you drive thru a snowstorm? A big puddle? Go 'muddin''? Just wondering if something got on one of the wheel ABS sensors, etc.

 

I'd try the battery reset....Of course, this doesn't 'fix' anything...The cause of the issue will come back. but depending on how quickly it comes back may give you a clue....but NOTE that you'll lose your radio presets and you MUST know how to re-program your keyless entry / fobs BEFORE doing this. 



#4 brus brother

brus brother

    Subaru Master

  • Members
  • 2,209 posts
  • Connecticut

Posted 24 November 2017 - 05:08 PM

Not so sure about the reprogramming of remotes. Have changed battery and never had to reprogram the remotes on my 08.

I use a cheapo scanner to scan and reset my 05 and 08 like the $15 one linked below:

LINK

It plugs into the terminal and doesn't require a computer or smart phone. Simple to use.

I have gotten error codes when I turned the key to the on position Before attaching the reader.

Correct sequence: key off/attach scanner tool/key to on position/hit scan button



#5 Fairtax4me

Fairtax4me

    Sooberoo

  • Members
  • 12,858 posts
  • Charlottesburg, VA

Posted 24 November 2017 - 10:48 PM

Traction control and cruise are disabled when the CEL comes on, so those lights turn on as well.

Sounds like you just need a newer code reader. Look into the Torque app if you have a non-iPhone.

#6 1 Lucky Texan

1 Lucky Texan

    I read a lot about Subarus. '03H6OBW,'06WRX

  • Members
  • 7,700 posts
  • Texas

Posted 25 November 2017 - 11:17 AM

will his 08 do the 'native' code display routine?

 

(agree on the canbus being likely reason old reader won't connect)



#7 john in KY

john in KY

    1000+ Super USER!

  • Members
  • 1,607 posts
  • KY

Posted 25 November 2017 - 01:45 PM

Ordered new code reader and from the photo noticed the plug has 16 pins whereas my old reader has far fewer.  Will know something next week when the new one gets here. 


Edited by john in KY, 25 November 2017 - 01:46 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users