Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Sputtering at 5 psi


  • Please log in to reply
2 replies to this topic

#1 05legacygtstage2

05legacygtstage2

    Newbie

  • Members
  • Pip
  • 6 posts
  • Greenville Sc

Posted 09 February 2018 - 11:20 AM

I recently bought a 05 legacy gt. It was stage 2 when I bought it. Catless down pipe, after market up pipe, full Cobb intake including intake Manifold , Cobb access port and straight pipe exhaust. It ran great at first. Now it is sputtering real bad around 5 psi. I took it to a shop and they can’t find anything wrong with it. I have seen on some of these forms that a lot of people have had this problem with stage 2 but not any Solutions. The only code on the car are about the manifold. I’m wondering it that’s not the problem. Anyone have any thoughts or advice? Thanks

#2 Olnick

Olnick

    Ol' Subaru Guy

  • Moderator
  • 3,064 posts
  • Honolulu HI

Posted 09 February 2018 - 11:41 AM

Welcome to the USMB.  You should post your question in the New Generation forum.



#3 05legacygtstage2

05legacygtstage2

    Newbie

  • Members
  • Pip
  • 6 posts
  • Greenville Sc

Posted 09 February 2018 - 11:44 AM

Ok thanks




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users