Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Loud ticking from gas tank area on startup 1994 legacy sedan


  • Please log in to reply
3 replies to this topic

#1 lizardbrain

lizardbrain

    New User

  • Members
  • PipPip
  • 29 posts
  • Baja California Sur

Posted 21 March 2018 - 11:48 AM

Hi all,

 

1994 legacy sedan 2wd 5speed 190k miles.  This is my 5th or 6th Subaru.

 

I've been driving this car for 3 or 4 years (and liking it) and the last couple of days, sometimes when I start it, there's a noticeable ticking or clicking noise coming from the gas tank area. It starts and runs fine, and ticking goes away after a minute or so.  I'm not smelling gas, but I haven't crawled under it to look for leaks.

 

Is my fuel pump going out? Filter clogged? Any ideas? I'd like to fix it before it quits on me, and in a month or so I'd like to take in on a couple of thousand mile trip. Thanks for any advice, short of get another car...

 

Pat



#2 forester2002s

forester2002s

    Subaru Fanatic!

  • Members
  • 869 posts
  • Vancouver Canada

Posted 21 March 2018 - 12:45 PM

What happens if you turn the key to ON, but don't start the engine? Still hear the clicking?

If so, try removing the fuse for the fuel-pump. Still hear the clicking?


Edited by forester2002s, 21 March 2018 - 01:22 PM.


#3 lizardbrain

lizardbrain

    New User

  • Members
  • PipPip
  • 29 posts
  • Baja California Sur

Posted 21 March 2018 - 08:31 PM

That's a good question,  it hasn't lasted more than a minute or so.

 

It's intermittent, I just tried it, and it's not ticking now . When the key is in the ON position, I can hear (barely) the fuel pump start for a second or so, then shut off.  It's not doing it (rapid clicking/ticking) every time I start it, and it's the first time I've heard this sound in any of my cars or motorcycles with pump in tank.  I have in tank pumps fail and they didn't always do it all at once. This sounds like a relay chattering, but I don't  know of any in back of the car.

 

When I first heard it, I thought it was one of the seat belt motors, but there aren't any of them back there. So far it hasn't lasted long enough to pick through the fuse box to see what it is, or even get out and look under the car to see if there's some exhaust system part knocking on the body.  The car does not have electric door locks, so it's not a lock actuator.

 

I am pretty good at trouble shooting, I spent a few years debugging code, and have been working with stuff with engines since the 70s.  I was hoping that someone had heard something like this and knew what it was.

 

I'll check rockauto to see if they have the pump access plate gasket or seal or whatever it is, and get one and a pump.  There are no subaru parts here, and it there was one in a junk yard, they would want twice of what a new one is.



#4 robertbelli13@gmail.com

robertbelli13@gmail.com

    Newbie

  • Members
  • Pip
  • 2 posts
  • Mount Vernon, WA

Posted 28 March 2018 - 06:23 PM

i have the same issue with my 07 impreza. ticking after i start the car but it doesnt go away for me and i havnt  gotten any answers yet.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users