Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Impreza just won't start


  • Please log in to reply
6 replies to this topic

#1 laichzeit

laichzeit

    New User

  • Members
  • Pip
  • 9 posts
  • Auckland

Posted 01 August 2004 - 11:57 PM

Hi there,
Im new to this forum and I need some help.
I own a 1993 Impreza WRX RA. I encountered some problems with it recently.
When the engine was cold, the check engine light used to come on until it warmed up, then it went off. The other day it stayed on, then yesterday I went to start the car and it just spluttered out 3 secs after I turned the ignition. I spent about 10 mins before it finally started and stayed on. Once again the check engine light stayed on the whole time(water and oil fine). Once again it fails to start, it just coughs then dies and the check engine and other warning lights come on. Does anybody have any idea on what is going on?
cheers

#2 Setright

Setright

    Elite Master of the Subaru

  • Members
  • 3,176 posts
  • Denmark

Posted 02 August 2004 - 12:16 AM

You need to get the codes read. The Check Engine thing is general warning, and it tells that one or more fault codes are stored in the ECU memory.

#3 Legacy777

Legacy777

    Moderator

  • Moderator
  • 12,630 posts
  • Houston, Tx

Posted 02 August 2004 - 08:10 AM

you can get info on how to check the codes on my site.

#4 laichzeit

laichzeit

    New User

  • Members
  • Pip
  • 9 posts
  • Auckland

Posted 02 August 2004 - 11:09 PM

Josh you are a legend!!
Using the info on your site I found out the problem is "Water temperature sensor" I'm guessing the results are the same for Impreza's as Legacy's.
Hope the new sensor fixes the problem. Do you think that this is the reason why the car fails to start for the first like 20 tries?
cheers

#5 Legacy777

Legacy777

    Moderator

  • Moderator
  • 12,630 posts
  • Houston, Tx

Posted 03 August 2004 - 08:18 AM

Yeah the codes should be the same for the OBD1 legacies and imprezas. and yeah I'd say the hard to start issues you're having are synonymous with the coolant temp sensor.

Let us know if that fixes the problem :)

#6 laichzeit

laichzeit

    New User

  • Members
  • Pip
  • 9 posts
  • Auckland

Posted 08 August 2004 - 04:26 PM

well I was right about the water temp sensor. But while they were fixing that they found the coolant tank had a a few holes in it which also contributed to the engine coughing and rough acceleration. so $320NZ later its sweet!
Thanks for ya help.

p.s Josh I had a Subie like your which I sold 2 days ago, heres a pic:
http://www.freepgs.c...hotos/Subie.JPG

#7 Legacy777

Legacy777

    Moderator

  • Moderator
  • 12,630 posts
  • Houston, Tx

Posted 09 August 2004 - 08:15 AM

nice looking legacy :) i really need to get my glass headlamps in....they look so much better then the plastic ones




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users