Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Happy Weber........


  • Please log in to reply
7 replies to this topic

#1 chef_tim

chef_tim

    Romans 5:8

  • Members
  • 4,780 posts
  • Renner, SD

Posted 11 August 2004 - 06:20 PM

I bought a set of jets from Big Jim Hilton, 140/140 mains, 60/55 idle, 165/160A/C. The difference is huge. Still not alot of top end, but it seems to hold it better now. Low end torque is great, you can feel it just tapping the peddal. Now to check milage, this fill up was 14 mpg:eek: , I might as well be driving a Hummer:lol: . Big thanks to Jim:clap: . Tim

#2 GeneralDisorder

GeneralDisorder

    Elite Master of the Subaru

  • Members
  • 20,281 posts
  • Portland

Posted 11 August 2004 - 06:31 PM

Ouchies! My wagon has the stock jets (140/140 mains - 170/160 A/C - 60/55 idle), and I have great power. Getting about 18-19 MPG with 28" rubber. It's weird how different the exact same jets can act on different cars. My friend's hatch doesn't have the power my wagon does, and it's got the same brand new Weber I have. Cheap labor in mexico I suspect....

GD

#3 archemitis

archemitis

    guy smiley

  • Members
  • 3,554 posts
  • the big minnie

Posted 11 August 2004 - 06:42 PM

im writing down those numbers and butting them in my wallet =]
this should be sticky, and stay at the top forever.

#4 VaporTrail

VaporTrail

    Brattitude Adjustment

  • Administrator
  • 11,160 posts
  • Central Iowa

Posted 11 August 2004 - 10:13 PM

I've got the 140 mains as well, but I'll be going back to my 155s :) since the problem I had was air related before. I was running my 155s at the midwest meet this year... lots of low end, just didn't have the clutch. that problem is taken care of too :)

I'm getting 17-18 mpg with mine right now. it still feels like I'm running short of air at the extreme top end.... but I will say that I love my 5 speed, much more than my original '82 4 speed from my Brat...

#5 Qman

Qman

    Happiness is... no lag!!

  • Moderator
  • 11,119 posts
  • Sumner

Posted 11 August 2004 - 10:53 PM

but I will say that I love my 5 speed, much more than my original '82 4 speed from my Brat...


...told ya' :-p

#6 VaporTrail

VaporTrail

    Brattitude Adjustment

  • Administrator
  • 11,160 posts
  • Central Iowa

Posted 11 August 2004 - 11:08 PM

:lol:

I even use 5th occasionally on the interstate. can't go any faster really, but saves on fuel a little....

I don't even like getting into my 86 any more!!!!!


...told ya' :-p



#7 edrach

edrach

    RIP 6/28/14

  • Members
  • 12,326 posts
  • Bothell, WA

Posted 12 August 2004 - 09:03 AM

I wonder if re-jetting will help my Brat pass emissions at idle?

#8 GeneralDisorder

GeneralDisorder

    Elite Master of the Subaru

  • Members
  • 20,281 posts
  • Portland

Posted 12 August 2004 - 11:15 AM

Perhaps. You can also try removing the secondary idle jet, and just plugging that off with a bolt. You don't need it, and it's probably dumping in extra fuel.

Are you just slightly out of spec? Mine jumped around at idle - first low, then really high. Turned out to be a cracked evap canistor causing a vac leak..... idle "quality" was poor.

Might try having a brand new cat welded up in place of the resonator pipe.....

GD




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users