Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Have a tranny fluid question


  • Please log in to reply
10 replies to this topic

#1 SubaruRichie

SubaruRichie

    USMB Regular

  • Members
  • PipPipPip
  • 87 posts

Posted 15 August 2004 - 05:48 PM

I need to know how much and what kind of fluid goes into my 78 brat 4 speed transmission. Just checked the level and it is almost empty. Help me out guys! Thanks.

#2 PeterD

PeterD

    Subaru Nut

  • Members
  • 562 posts
  • Renton/Cheney ( EWU )

Posted 15 August 2004 - 07:07 PM

I need to know how much and what kind of fluid goes into my 78 brat 4 speed transmission. Just checked the level and it is almost empty. Help me out guys! Thanks.


it should be around 2-2.5 quarts...my manual dosn;t go back to 78 though.

#3 dave valiant

dave valiant

    Subaru Nut

  • Members
  • 570 posts
  • Rapid City

Posted 15 August 2004 - 09:13 PM

Should be 80-90.

#4 SubaruRichie

SubaruRichie

    USMB Regular

  • Members
  • PipPipPip
  • 87 posts

Posted 16 August 2004 - 12:27 AM

That's 80 to 90 weight gear oil right? Just want to make sure.

#5 baccaruda

baccaruda

    YOUR FAVORITE MOM

  • Moderator
  • 6,950 posts
  • SpoVegas, WA

Posted 16 August 2004 - 12:56 AM

yes, the bottle will probably say 80-85w90 or something. get an extra bottle and change the soup in the rear differential too.
someone said that subaru transmissions like half synthetic and half natural gear oil in their manual trannies, and i noticed marginally smoother shifting after doing so in my wagon, FYI.

#6 SubaruRichie

SubaruRichie

    USMB Regular

  • Members
  • PipPipPip
  • 87 posts

Posted 16 August 2004 - 12:57 AM

Thanks, I appreciate the help.

#7 baccaruda

baccaruda

    YOUR FAVORITE MOM

  • Moderator
  • 6,950 posts
  • SpoVegas, WA

Posted 16 August 2004 - 12:58 AM

no problem!

#8 aprilspies

aprilspies

    USMB Regular

  • Members
  • PipPipPip
  • 30 posts
  • Easton

Posted 16 August 2004 - 01:26 AM

oooh i have a question for anyone reading.....i can't find any leaks or nasty spots under my car but i go through transmission fluid insanely fast. so, either there are secret gnomes who come and steal my fluid or i've got a big problem. I go through a bottle and a half to two bottles ever 3 weeks or so for the past 3-4 months.

#9 baccaruda

baccaruda

    YOUR FAVORITE MOM

  • Moderator
  • 6,950 posts
  • SpoVegas, WA

Posted 16 August 2004 - 01:37 AM

automatic or manual?

#10 aprilspies

aprilspies

    USMB Regular

  • Members
  • PipPipPip
  • 30 posts
  • Easton

Posted 16 August 2004 - 10:34 AM

it's an automatic.....and this is what is confusing....i have two places for fluid under my hood....the one is always fine and in my book that says manual....the one that's always dry is automatic.....

#11 JWX

JWX

    Lonely driver

  • Members
  • 3,073 posts
  • Atlanta

Posted 16 August 2004 - 11:40 AM

sounds like the seal between the front diff(is that the right term, guys?) and the tranny part of the transaxle is gone. I'd do a search on it, if I was you.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users