Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Help GL 10 guys


  • Please log in to reply
6 replies to this topic

#1 busdriver

busdriver

    USMB Regular

  • Members
  • PipPipPip
  • 98 posts
  • marquette

Posted 11 October 2004 - 08:40 AM

Hi Folks
2 questions. Is there a blow-off valve for the turbo, and where is it located? Second, how much up and down movement do you guys have in your shifter. I think I might have a bad tranny mount cause the shifter seems to jump pretty irratically when driving hard, and I heard a clunk underneath the center console when I was testing the clutch, the car was bucking when I let the clutch out with no gas and the clunk was in unison with the bucking. There is a new clutch pack in her, I think I need to adjust my clutch as well cause she bucked for a second and drove off.

#2 calebz

calebz

    Andys Coupe killed my cat

  • Administrator
  • 7,547 posts
  • Tacoma

Posted 11 October 2004 - 09:59 AM

No blow off valve. There is a dash pot that serves the purpose of not allowing the throttle plate to slam shut between shifts, thus giving the pressure somewhere to go. MAF cars don't particularily care for atmospheric BOVs..recric valves work just fine though. And since there is absolutely no performance gain to be had by using a BOV instead of a recirc valve, it doesn't make much sense to go through all the trouble of confusing the ECU with one.

shifter play up and down? Absolutely zero for me.

#3 WJM

WJM

    SUBARU

  • Members
  • 7,828 posts

Posted 11 October 2004 - 10:02 AM

sounds like a bad mount somewhere abouts the drivetrain....sheck all over the trans engine and ****er stuffs and see what you can find. Mine is nice and tight.

Install a recirc valve ASAP if you are driving really hard. Otherwise...say bye bye turbo somewhat sooner than later.

#4 rallyruss

rallyruss

    Subaru Master

  • Members
  • 1,653 posts
  • San Jose CA

Posted 11 October 2004 - 10:20 AM

the tranny mount is probably shot if you say the shifter jumps up and down.

you say you have a new cluth but it chatters? did the flywheel get resurfaced at the same time as the clutch replacement? if not that could be the cause.

calebz got the info on bypass vs blow off correct for you.

see I got you back calebz;)

#5 busdriver

busdriver

    USMB Regular

  • Members
  • PipPipPip
  • 98 posts
  • marquette

Posted 11 October 2004 - 10:51 AM

sounds like a bad mount somewhere abouts the drivetrain....sheck all over the trans engine and ****er stuffs and see what you can find. Mine is nice and tight.

Install a recirc valve ASAP if you are driving really hard. Otherwise...say bye bye turbo somewhat sooner than later.

I'm going to look for the mount issue tonight hopefully if I can find some help. I don't plan on driving her hard at all. I worry about breaking her in the dead of winter and not having the means to fix her. I really appreciate the replies, thanks.

#6 busdriver

busdriver

    USMB Regular

  • Members
  • PipPipPip
  • 98 posts
  • marquette

Posted 11 October 2004 - 10:56 AM

the tranny mount is probably shot if you say the shifter jumps up and down.

you say you have a new cluth but it chatters? did the flywheel get resurfaced at the same time as the clutch replacement? if not that could be the cause.

calebz got the info on bypass vs blow off correct for you.

see I got you back calebz;)

Thank god I have all the receipts from everything ever done to this subie before I got it. The clutch was resurfaced I believe. On one of the receipts it mentiond they pulled the flywheel for "machining". I would interpret this to means resurfacing. Thanks for the info.

#7 rallyruss

rallyruss

    Subaru Master

  • Members
  • 1,653 posts
  • San Jose CA

Posted 11 October 2004 - 02:46 PM

Thank god I have all the receipts from everything ever done to this subie before I got it. The clutch was resurfaced I believe. On one of the receipts it mentiond they pulled the flywheel for "machining". I would interpret this to means resurfacing. Thanks for the info.


thats good hopefully its just a couple of broken tranny mounts. check the motor mounts too.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users