Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

how do you install oil pressure gauge?


  • Please log in to reply
5 replies to this topic

#1 avatar382

avatar382

    USMB is life!

  • Members
  • 182 posts

Posted 21 October 2004 - 03:47 PM

My car has an aftermarket oil pressure gauge in the dash, but it no worky. Apparently the previous owner could not find a fitting for it. (whatever that means, I'm dumb)

So, I have this clear plastic tube thing from the gauge in my engine bay. I know where the sending unit is, but is it simply a matter of fitting this plastic tube onto the sending unit? Or does it replace the sending unit? Or do I need a new sending unit? Also, what can I do if the clear plastic tube thing doesn't reach to the oil pump area? Can I extend it with a similair piece?

Also the wire extending from the sending unit now I assume is for the idiot light on the dash. Is there a way to have both the oil pressure gauge and the idiot light working?

Thanks!

#2 MorganM

MorganM

    Do you Subaru?

  • Members
  • 8,390 posts
  • TwinCities

Posted 21 October 2004 - 05:20 PM

Need a fitting that replaces your electric sending unit there on your pump. The fitting screws right in and the hose comes out of it upto the guage. Get enough tube to reach the whole length; I would advise against using couplers and extending the line. That would be just one more point of failure in your oil system. The guages I've setup came with several fittings so you could mix and match to fit your application. Also came with a little bit of thread sealer. Dunno where you'd find just the brass fittings and tube by itself.

#3 Snowman

Snowman

    Midnight Passenger

  • Members
  • 3,538 posts
  • Haines

Posted 21 October 2004 - 08:03 PM

Take the factory sending unit out and take it down to Lowe's or Home Depot, and find a fitting that is the same thread type, then find a compression fitting to go on your plastic hose, and then somehow adapt them together.

I second the idea of not putting multiple hoses together because it does increase the chance of failure. And it that failed, it could mean catastrophic engine failure.

#4 carfreak85

carfreak85

    EA81T Sherpa

  • Members
  • 4,786 posts
  • Bell-something...

Posted 21 October 2004 - 08:06 PM

The thread in the block is an NPT fitting, so I had to get a NPT to SAE adapter and then a brass "T". I put the idiot light sender in one of the open ports on the "T" and the oil pressure gauge on the other port. I also used teflon tape on all the threads in the system to ensure leak-free operation. I can get pics this weekend if you'd like.

#5 archemitis

archemitis

    guy smiley

  • Members
  • 3,554 posts
  • the big minnie

Posted 21 October 2004 - 08:19 PM

just noticed i was responding to this post on the xt6 board...
=P

#6 Flow

Flow

    Eat, Live, Breath Subaru

  • Members
  • 257 posts
  • Roy

Posted 21 October 2004 - 10:05 PM

I was looking for some answers to the same question awhile ago.

http://www.ultimates...light=oil guage

I ended up tapping the idiot light hole in the oil pump with a 1/8 NPT tap. I used lots of grease in the flutes of the tap and took my time cleaning the tap often. I also bought a like 10 feet of copper tubing to plumb it with. It was actually cheaper than the kit with plastic tubing which had a bunch of stuff I didn't need. Good luck.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users