Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

'95 Legacy-no reverse; need new tranny?


  • Please log in to reply
1 reply to this topic

#1 wtdash

wtdash

    Subaru Nut

  • Members
  • 771 posts
  • N. ID

Posted 30 October 2004 - 11:08 AM

Hello,
New to the forum....My 104K mile subie goes forward fine, but reverse is the same as Neutral. This occurred after a tranny flush- Reverse worked for a couple days, but is completey gone now. It either worked or not at all...there isn't/wasn't any slipping.

I've read posts about no reverse causes: control valve, solenoid. After having 2 diagnoses - independent and AAMCO- told basically the same thing: rebuild time. The indie shop said they could repair the "drum (?)" for $975- rebuild (includes TC) is $1500. AAMCO wants $1800 to start...rebuild would obviously be even more.

Thanks for all the info on this site.

Todd

#2 Legacy777

Legacy777

    Moderator

  • Moderator
  • 12,576 posts
  • Houston, Tx

Posted 31 October 2004 - 12:42 PM

Yeah.....you pretty much need a new tranny. You may want to look at trying to get a low mileage tranny. It may be cheaper then having it rebuilt.

If you decide to have it rebuilt I'd stay away from AAMCO. I haven't heard anything good about them. You may want to ask around on the board as well other people in your area for a good trans shop.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users