Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

clunk.....clunk....sound after lift install of steering


  • Please log in to reply
20 replies to this topic

#1 monstaru

monstaru

    wow, relevance....

  • Members
  • 4,403 posts
  • OlyWa

Posted 25 November 2004 - 07:51 PM

i drove her for the first time today around the neighborhood and had a bad sound .tires are definitely not hitting anything.i checked to make sure the steering arm was on right and it is.any ideas about this.is this a common phenomenon?help thanks, brian

#2 monstaru

monstaru

    wow, relevance....

  • Members
  • 4,403 posts
  • OlyWa

Posted 25 November 2004 - 11:48 PM

anyone?

#3 Numbchux

Numbchux

    EJ conversion addict

  • Members
  • 5,991 posts
  • Duluth, MN

Posted 26 November 2004 - 01:07 AM

don't quote me on this, but isn't there something on EA81's that needs a little, uh, careful sledge treatment, to allow the suspension to work properly? I don't have the time/patience now, but maybe poke around a bit.

#4 monstaru

monstaru

    wow, relevance....

  • Members
  • 4,403 posts
  • OlyWa

Posted 26 November 2004 - 01:29 AM

yeah,i heard that to and did not want to bekieve it......maybe i am just a *******......live and learn.gonna go look at it right now.

#5 TheSubaruJunkie

TheSubaruJunkie

    I'M BAAAAAACK!

  • Members
  • 1,921 posts
  • Sacramento

Posted 26 November 2004 - 02:05 AM

Posted Image-Brian

#6 monstaru

monstaru

    wow, relevance....

  • Members
  • 4,403 posts
  • OlyWa

Posted 26 November 2004 - 02:32 AM

it is the spring turning in the mount...anyone know anything about this, ever happen to you?

#7 TheSubaruJunkie

TheSubaruJunkie

    I'M BAAAAAACK!

  • Members
  • 1,921 posts
  • Sacramento

Posted 26 November 2004 - 03:49 AM

yeah, your mount isnt supposed to stand still is it? Make sure its not stuck on that hump.

-Brian

#8 monstaru

monstaru

    wow, relevance....

  • Members
  • 4,403 posts
  • OlyWa

Posted 26 November 2004 - 03:54 AM

thats what i was thinkin.....time to get the bfh out.....thanks junkie

#9 TheSubaruJunkie

TheSubaruJunkie

    I'M BAAAAAACK!

  • Members
  • 1,921 posts
  • Sacramento

Posted 26 November 2004 - 05:36 AM

I had to remove my struts after I 1st installed the lift (pain inthe arse). But after speakin with Zap that day, he clued me in. I'm not sure if PK put that in his instructions yet, but i figured i'd get a shot of the area. With the 3" lift you shouldnt need to beat it too hard.

-Brian

#10 Sweet82

Sweet82

    Elite Master of the Subaru

  • Members
  • 3,266 posts
  • Salt Lake City

Posted 26 November 2004 - 11:13 AM

I guess that makes it "Hammer Time" :brow:

Beat that into submission! :banghead:

#11 monstaru

monstaru

    wow, relevance....

  • Members
  • 4,403 posts
  • OlyWa

Posted 26 November 2004 - 01:57 PM

it's not 3 my brotha, it's 4inches, yes count 'em.....4 inches(what other time in a mans life would he be bragging about 4 inches)?gonna have a look as soon as the bfh gets here with baccaruda.

#12 singletrack

singletrack

    EA Abuser

  • Members
  • 536 posts
  • Palisade, Colorado

Posted 27 November 2004 - 11:33 PM

i drove her for the first time today around the neighborhood and had a bad sound


My recently lifted wagon makes noise when steering.... as far as I can tell it's the extended steering shaft clunking. I've more or less traced the vibration back to there, and it happens at the same point on every turn of the wheel ie; if it clunks when my hand is at 12 oclock and I turn the wheel, it'll clunk again when my hand gets back to 12.

I've choosen to ignore it.

#13 Flowmastered87GL

Flowmastered87GL

    WCSS Drunk

  • Members
  • 6,115 posts
  • Portland, Oregon

Posted 28 November 2004 - 12:37 AM

I dont think mine rubs, mine is a 3 inch. It better not! everything is bolted together though and I have rolled it around the parking lot with no issues (other than a hyperextended CV joint)

#14 TheSubaruJunkie

TheSubaruJunkie

    I'M BAAAAAACK!

  • Members
  • 1,921 posts
  • Sacramento

Posted 28 November 2004 - 01:00 AM

Mike, you would know if it was rubbing if you couldnt steer. The problem I had was steering from lock to lock. The struts would catch on that hump, and would keep the strut from rotating. Resulting in a loud "THUD" once it did get past the hump.

Not sure if this is what Monstaru is having, but it might be the source of his problem.

-Brian

#15 Flowmastered87GL

Flowmastered87GL

    WCSS Drunk

  • Members
  • 6,115 posts
  • Portland, Oregon

Posted 28 November 2004 - 01:08 AM

I've never gotten to lock yet... I have like 28 inch tires and they rub the fenders so I can turn em enough yet til I BFH them.

#16 monstaru

monstaru

    wow, relevance....

  • Members
  • 4,403 posts
  • OlyWa

Posted 28 November 2004 - 03:42 AM

i was supposed to address this today.didn't happen.tomorrow will be the day of reckoning.baccaruda and i looked at the situation and it appears to be the top of the strut mount hitting the fender.and then the strut spring is flipping around and clunking as it seats in the proper spot.......i believe it simply needs the bfh.we will see tomorrow.

#17 baccaruda

baccaruda

    YOUR FAVORITE MOD

  • Moderator
  • 6,942 posts
  • SpoVegas, WA

Posted 28 November 2004 - 05:03 AM

that's exactly what it was doing. we'll take care of this tomorrow.. (sunday)

Mike, you would know if it was rubbing if you couldnt steer. The problem I had was steering from lock to lock. The struts would catch on that hump, and would keep the strut from rotating. Resulting in a loud "THUD" once it did get past the hump.

Not sure if this is what Monstaru is having, but it might be the source of his problem.

-Brian



#18 TheSubaruJunkie

TheSubaruJunkie

    I'M BAAAAAACK!

  • Members
  • 1,921 posts
  • Sacramento

Posted 28 November 2004 - 03:03 PM

GLad to hear it was something simple :)

The BFH is your best friend when a lift install is done. That, and a pnumatic toolset :)

-Brian

#19 DaveAP

DaveAP

    Subaru Fanatic!

  • Members
  • 386 posts
  • Prescott, Arizona

Posted 28 November 2004 - 10:05 PM

Did you have any other symtoms with this? I have had hell trying to figure out what is going on with my lifted '78 brat. When it shows a loud clunk is it hard for you to turn the steering wheel, then once it clunks it frees up and you can continue turning the wheel? I have noticed a shiny spot on the fender near the strut, maybe that is my problem.

thanks, dp

#20 monstaru

monstaru

    wow, relevance....

  • Members
  • 4,403 posts
  • OlyWa

Posted 28 November 2004 - 10:14 PM

that sounds like what i ahev encounterd.pound that sucker out......i have yet to rectify,due to other interest(kicking some rump roast at horseshoes).but will actually be doing it on the morrow

#21 monstaru

monstaru

    wow, relevance....

  • Members
  • 4,403 posts
  • OlyWa

Posted 04 December 2004 - 06:44 PM

just to clarify.....that was the monster iwas fighting......time has been slim.got to it yesterday.man does that make a difference.no more hump.no more clank-clank.got the title to her today....will be driving her soon,stoked




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users