Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

92 Legacy LS "wiggle"


  • Please log in to reply
4 replies to this topic

#1 falling

falling

    New User

  • Members
  • PipPip
  • 26 posts
  • Edmonton, Alberta

Posted 16 August 2003 - 03:07 PM

Just picked up a '92 Legacy LS wagon (#5 sooby for me) and it has a "wiggle" when accelerating and cornering. It feels like it shifts to the left on acceleration and to the right hen you come off the throttle. Also a catching or binding feeling when cornering hard. I have heard it could be the clutches in the AWD system. If so, any repairs that woin't cost a ton of money? or suggestions to relieve the binding? Tks in advance for your help.

#2 DerFahrer

DerFahrer

    Formerly subyluvr2212

  • Members
  • 2,411 posts
  • Orlando, FL

Posted 16 August 2003 - 04:22 PM

I'm trying to track down a similar problem. On a very rare occasion, seems to be in the wet mostly :banghead: , I have a very violent feeling of shaking and looseness from the rear end. Yet I never skid or spin or hint of losing control.

I have a couple theories, which I will attend to soon, like swaybar bushings, extra crap in trunk, and yes, possibly a drivetrain problem...

#3 falling

falling

    New User

  • Members
  • PipPip
  • 26 posts
  • Edmonton, Alberta

Posted 18 August 2003 - 12:18 PM

Mine is quite violent as well when driving it hard, but havn't tried it out in the rain or slipperys yet. I have been talking to the local subaru techs and I put a fuse in to disable the AWD to FWD only. The wiggle is almost totally gone, just a little pull now on acceleration and decelleration. They are of the opinion it is the clutches in the transfer case that are binding. Now just a matter of time and money to fix it. Any one else have any opinions or ideas?

#4 calebz

calebz

    Andys Coupe killed my cat

  • Administrator
  • 7,547 posts
  • Tacoma

Posted 18 August 2003 - 12:24 PM

Uneven wear/mismatched tires? that might cause binding as well

#5 falling

falling

    New User

  • Members
  • PipPip
  • 26 posts
  • Edmonton, Alberta

Posted 18 August 2003 - 03:56 PM

Tires were all replaced last year by the previous owner. was ne of the first things I looked at when I bought the car.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users