Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Freakin'A


  • Please log in to reply
16 replies to this topic

#1 WJM

WJM

    SUBARU

  • Members
  • 7,828 posts

Posted 15 December 2004 - 06:48 PM

More clutch slip. 11 PSI now. ARG.

Weird issues with stumbling and no power when just puttzing around....but when i drive it like its a waaceee Kaaa...its fine for a while....puttzz around...20 mins of that and it complains. :banghead:

AND....the gremlin fuel cut is still there. Power door locks dont work. The passenger and hatch locks are....well, dont really operate on key use...they sound like pastic breaking when its turned....AND!!!!!!!!!!!!! and.....the rear speakers suck.....ADN!!!!!!!!!!!!!! adn....well, and.....ummm....its really cold out side.

Im done. :lol:

#2 Turbone

Turbone

    The Original Rob

  • Moderator
  • 12,159 posts
  • WA

Posted 15 December 2004 - 08:58 PM

Will, I hate to say it. But your turning into a perpetual whiner :rolleyes:
And a post w#$%e ;)

#3 TheSubaruJunkie

TheSubaruJunkie

    I'M BAAAAAACK!

  • Members
  • 1,921 posts
  • Sacramento

Posted 15 December 2004 - 09:08 PM

Hahaha. Is this all on the RX? My RX doesnt have power door locks. And well... you knew your clutch was going to slip. Didnt you? How is the WRX clutch disc project turning out?

-Brian

#4 WJM

WJM

    SUBARU

  • Members
  • 7,828 posts

Posted 15 December 2004 - 09:18 PM

whinner? No...but I like to keep USMB up to date on whats going on in the Mad SCientists project cars... :rolleyes:

Post w^%*...maybe... :rolleyes: :lol:

Yep, all on the RX...and I think all the RXs are supposed to have PDRs...and i didnt know that the ENGINE would put out that much power to make it slip with just putting the IC on.... :confused: ....it too spyder intake, large TB and special more fuel in the top end to make the wagon slip like the RX is slipping now... :confused: oh well...

I hope either SOA will come thru and give me a clutch...or im getting one of the clutchnet x puck clutches VERY soon.

According to a few sources...the clutches on all the EJxx AWD stuff is the same as the 4WD/Turbo EA82 and some EA82 stuff. the 6MT STi stuff has a larger clutch disc, so thats out ofcourse.

Otherwise, it appears as if thickness: 5MM. Diameter: 225MM/8.875IN, spline/teeth: 1/T24....are all the same on the stuff across the board.

Ofcourse, flywheels and presure plates are a difference between many things and NOT compatible at all between EAxxx/EJxxx....

#5 Subarutex

Subarutex

    Oldschool Show Queen

  • Moderator
  • 2,540 posts
  • Mountlake Terrace

Posted 16 December 2004 - 12:15 AM

Dude, your power door locks don't work cause you don't have any.

Coupe = No door locks. Just lean over and lock it slacker!!

#6 JWX

JWX

    Lonely driver

  • Members
  • 3,073 posts
  • Atlanta

Posted 16 December 2004 - 01:07 AM

all three of mine has them.

#7 Subarutex

Subarutex

    Oldschool Show Queen

  • Moderator
  • 2,540 posts
  • Mountlake Terrace

Posted 16 December 2004 - 02:38 AM

my rx doesn't have them (87)

4 doors have a follower system as well.

#8 JWX

JWX

    Lonely driver

  • Members
  • 3,073 posts
  • Atlanta

Posted 16 December 2004 - 02:42 AM

maybe the 87s don't have them. does yours have power windows?

#9 Subarutex

Subarutex

    Oldschool Show Queen

  • Moderator
  • 2,540 posts
  • Mountlake Terrace

Posted 16 December 2004 - 03:22 AM

yes

#10 WJM

WJM

    SUBARU

  • Members
  • 7,828 posts

Posted 16 December 2004 - 07:26 AM

its supposed to have it.

#11 JWX

JWX

    Lonely driver

  • Members
  • 3,073 posts
  • Atlanta

Posted 16 December 2004 - 12:46 PM

well crapizza I was hoping for some lighter doors :)

#12 TheSubaruJunkie

TheSubaruJunkie

    I'M BAAAAAACK!

  • Members
  • 1,921 posts
  • Sacramento

Posted 16 December 2004 - 12:58 PM

My 87 has no power door locks, but does have power windows. If they dont work, stop being lazy and just lean over ;P

-Brian

#13 WJM

WJM

    SUBARU

  • Members
  • 7,828 posts

Posted 16 December 2004 - 01:41 PM

blah blah blah blah blah blah ...............

#14 Caboobaroo

Caboobaroo

    USMB Drunk

  • Members
  • 6,921 posts
  • Oregon City

Posted 16 December 2004 - 04:01 PM

mine have power door locks and windows as well. I guess you'll have to sell it Will and find a newer one:D Or quit whining about not having power door locks:brow:

#15 PoorManzImpreza

PoorManzImpreza

    Subaru Nut

  • Members
  • 546 posts
  • BARBADOS

Posted 17 December 2004 - 12:26 AM

mine have power door locks and windows as well. I guess you'll have to sell it Will and find a newer one:D Or quit whining about not having power door locks:brow:

or intall 'em like I did:brow:

#16 nkx

nkx

    Rallycross Junkie

  • Members
  • 891 posts
  • Carlisle, PA

Posted 17 December 2004 - 01:09 AM

im listening in on the wrx clutch rumor... i know im going to be needing a new one, especially after the IC goes in and the boost goes up!

#17 Adam N.D.J.

Adam N.D.J.

    Quite Rusty, but working.

  • Members
  • 3,290 posts
  • Medford, Oregon

Posted 17 December 2004 - 02:02 AM

My 3-dr has PDL's. Hmm. I was in the shed the other day, and I think I have a glove box out there with all the PDL stuff in it...




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users