Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Justy ECVT


  • Please log in to reply
4 replies to this topic

#1 simmo7

simmo7

    New User

  • Members
  • Pip
  • 2 posts
  • Dunedin - NZ

Posted 02 January 2005 - 06:31 PM

Hi, Ive just aquired a 91 Justy ECVT 4WD.
It has problems with transmission - fixed with new brushes but now it has lost its drive again. Brushes are wet with oil - should this be?
Also was very noisy at low speeds (grinding noise) but good at higher speeds.
Anybody know where I can get info on this transmission.
Cheers
Simmo7

#2 bratsrus1

bratsrus1

    Race car

  • Members
  • 1,295 posts
  • Selah Washington

Posted 02 January 2005 - 06:47 PM

Hey Simmo This is Jerry, my son had one of those cars. Same problem with it, to answer problem #1 no oil on the brushes you have a leak. Problem #2 it's inside of the tranny with the pulley set up, it's ready to take a dump. I swap it out with the manual 5 speed not that hard to do. Good luck with that tranny only has problems once they start. Thanks Jerry

#3 simmo7

simmo7

    New User

  • Members
  • Pip
  • 2 posts
  • Dunedin - NZ

Posted 03 January 2005 - 03:20 PM

Hey Simmo This is Jerry, my son had one of those cars. Same problem with it, to answer problem #1 no oil on the brushes you have a leak. Problem #2 it's inside of the tranny with the pulley set up, it's ready to take a dump. I swap it out with the manual 5 speed not that hard to do. Good luck with that tranny only has problems once they start. Thanks Jerry



Thanks Jerry
Do you know if they made a regular auto trans for the justy and if it can be put into my ecvt?
Cheers

#4 gtman

gtman

    New User

  • Members
  • Pip
  • 1 posts
  • Calgary

Posted 07 January 2005 - 11:39 PM

Hi, Ive just aquired a 91 Justy ECVT 4WD.
It has problems with transmission - fixed with new brushes but now it has lost its drive again. Brushes are wet with oil - should this be?
Also was very noisy at low speeds (grinding noise) but good at higher speeds.
Anybody know where I can get info on this transmission.
Cheers
Simmo7

I have one of those car and would like to buy a back up set of the brushes as I need to keep the car running as long as possible. I haven't had any problems yet but have read about the brushes going. I talked to the Subaru dealership and they said they couldn't get the brushes, where did you find them?
Any help about these cars would be a great help.
gtman

#5 Esteban32696

Esteban32696

    USMB is life!

  • Members
  • 158 posts
  • Florida

Posted 08 January 2005 - 06:41 AM

There was not another auto tranny for the Justy. Replace with 5 spd or sell. Costs $$$$ to rebuild if you can find the parts.

I have seen brushes on E Bay before. Also, post a " Wanted" ad on this Justy forum==
http://subarujusty.proboards20.com/




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users