Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

battery/idle problems


  • Please log in to reply
2 replies to this topic

#1 91' loyale man

91' loyale man

    New User

  • Members
  • PipPip
  • 11 posts
  • Arcata, Ca

Posted 06 January 2005 - 04:16 PM

Okay this is a hard one to explain! bear with me please. I have recently been having problems with my idle, whenever the car idle's high the battery goes out and the car dies. Before the car was only doing this when I turned the wheel all the way to the left or the right and all the red indicater lights would go on then the battery gauge whould read a lower voltage. Im thinking it possibly could be the alternater but it seems to be working fine or even a faulty battery. I recently change the alt/power steering belt thinking it would help but to no avail, any pointers. THe check engine light will also go on when the car is stoped everyonce in a while and the rpm's will go from 900 to 1000 very quickly(the car is 91 loyale).

#2 Ross

Ross

    Can't be bothered

  • Members
  • 1,865 posts
  • Christchurch, New Zealand

Posted 06 January 2005 - 04:49 PM

Have the diode bridge in the alternator checked by an auto electrician - alternating current in your electrical system can do some weird things.

#3 91' loyale man

91' loyale man

    New User

  • Members
  • PipPip
  • 11 posts
  • Arcata, Ca

Posted 06 January 2005 - 09:20 PM

does anyone think there is a possibility of it being a battery problem?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users