Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Timing belt covers


  • Please log in to reply
5 replies to this topic

#1 karinvail

karinvail

    Eat, Live, Breath Subaru

  • Members
  • 325 posts
  • Skagit County

Posted 28 February 2005 - 12:59 PM

I've never noticed problems with the timing belt covers on any previous Subie's I've owned, but this one (an 86 GL 4x4 wagon) has melted and cracked covers. I priced new ones and they aren't cheap - and looked in junk yards and they seem to have the same problem. A friend of my husband said to just take them off and run it w/o them. Sounds risky to me, but I'm a 'girl' - what do I know? LOL

#2 MorganM

MorganM

    Do you Subaru?

  • Members
  • 8,390 posts
  • TwinCities

Posted 28 February 2005 - 01:07 PM

Lots of ppl here run with out them. I've had one pulley bearing fail since then. I also take the time now to lubricate them often; especially in a MN winter with all the salt and sand! :(

Are they interfering with anything in their current conditoin? As far as protective shields; they are better in their current shape than none at all :) If they arent harming your belts or rubbing on any pullies I'd just leave them untill you find a nice junkyard set.

#3 hooziewhatsit

hooziewhatsit

    I fix old cars

  • Members
  • 1,333 posts
  • Klamath Falls

Posted 28 February 2005 - 01:14 PM

I think when I get around to doing the belts on my wifes car, I'll cut the middle one so I can get it off without taking off the crankshaft pulley. Then I'll leave the rest of them on.

That being said, I pretty much need to get a new set also. When taking the side covers off, the bolts all stripped out, so I got to use the screwdriver/prying to get them off... grr...

#4 85Sub4WD

85Sub4WD

    EA82 Junkie

  • Members
  • 1,244 posts
  • Raleigh NC/Charlotte NC

Posted 28 February 2005 - 02:49 PM

Mine are 20 years old, and in fairly rough shape, but they still do their job. I have thought about running without them, but I have seen a oil pump pully bent because of running w/o covers and a rock getting in there - so I feel that there should be something there to protect the belts.

Realize they are covers - they don't have to be pretty, they just have to cover the belts.

#5 grossgary

grossgary

    Elite Master of the Subaru

  • Members
  • 20,058 posts
  • WV

Posted 28 February 2005 - 04:22 PM

i run without them. before i ran without them i had 3 failed bearings and a broken oil pump pulley (which snapped the timing belt) WITH timing covers, so i wouldn't blame any failure of that sort to running without covers. that's with alot of miles of driving on a couple XT6's.

i think it's most beneficial if you're doing the work to your own car, makes timing belt replacement super quick and super easy. if you don't, i wouldn't worry about it unless they're in the way somehow. i've seen them rubbing belts before if they are contorted or deformed enough.

#6 edrach

edrach

    RIP 6/28/14

  • Members
  • 12,326 posts
  • Bothell, WA

Posted 28 February 2005 - 09:53 PM

One answer to the bolts seizing up is to apply never-seeze to the bolts when re-attaching the covers.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users