Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

ignition coil


  • Please log in to reply
3 replies to this topic

#1 96LegacyGT

96LegacyGT

    New User

  • Members
  • Pip
  • 9 posts
  • vernon

Posted 13 March 2005 - 09:38 AM

im wondering if having a bad ignition coil could cause the car to burn oil, and what are the symtoms for having a bad coil? my car burns like a half quart a wk depending on how much i drive but theres no oil puddles and no smoke out the tailpipe i fixed my crankshaft seal, pcv valve ,plugs wires etc .when i drive the car normal i press the gas and the car wont go and then all the sudden it kicks in .it seems like it happens more on acceleration going up hills does anyone have ideas 4 me does this sound like a bad coil

#2 kmix99

kmix99

    USMB Regular

  • Members
  • PipPipPip
  • 76 posts
  • williamsport pa

Posted 13 March 2005 - 09:47 AM

A bad ignition coil would not cause your oil consumption. A misfire, hard starting and fouled plugs are symptoms of a faulty coil. There are simple tests you can do at home to check your coils and plug wires using a volt meter (see a Haynes Subaru Manual). Some autoparts stores will test them for free if you bring it in to them.

#3 SevenSisters

SevenSisters

    Subaru Nut

  • Members
  • 512 posts
  • Cleve/Akron Ohio

Posted 13 March 2005 - 09:48 AM

Unless your have a bad running engine, thowing codes I doubt it.
A bad coil should result in a misfire code.
A bad coil pack that resulted no spark to a cylinder could result in unburned fuel dilluting the oil, causing abnormal wear, leading to oil burning.

#4 Cougar

Cougar

    Elite Master of the Subaru

  • Members
  • 6,340 posts
  • Anchorage

Posted 13 March 2005 - 10:37 AM

The piston rings or valve seals will deal with the oil problem. You could try changing the PCV valve again to see if that helps.

The misfire could be due to a bad plugwire or plug. If you have a throttle position sensor then check that for a dirty contact wiper. I doubt that the coil is causing these problems.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users