Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

trans "hunts "in drive 90Legacy


  • Please log in to reply
1 reply to this topic

#1 jozh7

jozh7

    New User

  • Members
  • Pip
  • 2 posts
  • reading

Posted 16 March 2005 - 08:36 PM

just had motor pulled for head job. now its finished and 1st & 2nd gear shift as
normal in gear selector 1 & 2 position. Indrive or 3 it will constantly downshift
at any speed with even the slightest acceleration. It almost seems that
it's not going into 3rd or 4th and if it does it wont stay. please help!!!
also looks like trans is electronic controlled? I saw no vacuum lines or
adjustment. It was ok before motorwork.

#2 Legacy777

Legacy777

    Moderator

  • Moderator
  • 12,566 posts
  • Houston, Tx

Posted 16 March 2005 - 10:45 PM

yes the trans is electronically controlled.

I'd make sure that all the connections are secure for the electrical connectors. Is the check engine or power light on or blinking?

You may want to reset the ECU & TCU. maybe something got changed when they had the motor out.

Instructions for resetting can be found on my site under the notes & tips section, engine related.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users