Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Camber


  • Please log in to reply
4 replies to this topic

#1 Mykeys Toy

Mykeys Toy

    Subaru Master

  • Gold Subscribers
  • 1,930 posts
  • South Prairie, Wa

Posted 18 March 2005 - 08:11 PM

I had my 86 Hatch aligned about a year ago and the camber was never right.. So I tried lowering the front to see if it would help.. Nada. The car is still removing the outside edge of the tire on drivers side.. It was affecting the passenger side too but the lowering of the front end seems to have stopped the wear on that side. Is there anything else that will cause the camber to be way off like that? The front is cranked down as far as it will go.

Mike

#2 RenaissanceMan

RenaissanceMan

    Sick in the Head 4 Subaru

  • Members
  • 706 posts
  • Atascadero

Posted 18 March 2005 - 11:03 PM

a bent macpherson strut or spindle can cause camber and steering axis inclination to be all out of whack. Also you might want to inspect the inner control arm bushings to see if they arent collapsed.

#3 Mykeys Toy

Mykeys Toy

    Subaru Master

  • Gold Subscribers
  • 1,930 posts
  • South Prairie, Wa

Posted 19 March 2005 - 12:20 AM

How whould I check those, or rather what am I looking for?

#4 Turbone

Turbone

    The Original Rob

  • Moderator
  • 12,087 posts
  • WA

Posted 19 March 2005 - 12:49 AM

The lower control arm has a bushing at the x-member, see if its loose. If you cant find the problem, bring it by my place this weekend.

#5 [ i ]nsane

[ i ]nsane

    Banned

  • Banned
  • PipPipPip
  • 58 posts

Posted 20 March 2005 - 05:27 PM

Possible ball joint problem




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users