Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Custom fit a-pillar pod


  • Please log in to reply
15 replies to this topic

#1 Caboobaroo

Caboobaroo

    USMB Drunk

  • Members
  • 6,861 posts
  • Oregon City

Posted 31 March 2005 - 01:31 PM

I recently got a 3 gauge a-pillar pod from a guy over on NASIOC for 20 bucks shipped. My goal was to modify it to fit into the RX since I need something to hold all of my wonderful gauges in a nice visible spot. Well it took me about a half hour, a hacksaw, and a file and I got it mounted all nicely in the car. Almost looks like it came this way from Autometer!
http://community.web...310448772MeSsZX

What do y'all think?

Yes I know, the dash is still torn apart because I'm still trying to get the rest of the wiring from the automatic out of there:rolleyes:

#2 TheSubaruJunkie

TheSubaruJunkie

    I'M BAAAAAACK!

  • Members
  • 1,921 posts
  • Sacramento

Posted 31 March 2005 - 09:12 PM

I hate those things, so i'll try to keep it as nice as possible :)

Looks like it fit.

-Brian

#3 calebz

calebz

    Andys Coupe killed my cat

  • Administrator
  • 7,547 posts
  • Tacoma

Posted 31 March 2005 - 09:25 PM

No pic came up.

Maybe try the onboard hosting here?

#4 Caboobaroo

Caboobaroo

    USMB Drunk

  • Members
  • 6,861 posts
  • Oregon City

Posted 31 March 2005 - 11:03 PM

Well thanks for not getting to carried away Brian.

Hmm i just tried it and the pic came up. Maybe its your computer Caleb:-p

#5 calebz

calebz

    Andys Coupe killed my cat

  • Administrator
  • 7,547 posts
  • Tacoma

Posted 01 April 2005 - 12:14 AM

Hmm i just tried it and the pic came up. Maybe its your computer Caleb:-p


Nope.. tried it on 3 of the 5 computers here.. Its working now though.. was probably the crappy hosting service you like to use :-p


Doesn't look too bad.. I Looked at using the same pod at one time and determined it was just too big for an EA82 car.. sure it can fit (as you have shown).. but the gauges stuck out too far IMO.

Not too bad though.. it uhh.. goes well with the steering wheel and shifter....

#6 Flowmastered87GL

Flowmastered87GL

    WCSS Drunk

  • Members
  • 6,094 posts
  • Portland, Oregon

Posted 01 April 2005 - 02:45 AM

I think it fit pretty good. Make sure the guages light so you can strike fear into the hondas :cool:

#7 GLCraig

GLCraig

    Livin' the live

  • Members
  • 2,706 posts
  • LV, Washington

Posted 01 April 2005 - 02:52 AM

I think it fit pretty good. Make sure the guages light so you can strike fear into the hondas :cool:


Like the guy who was caught doing 140+ in is civic, on 205 the other night? He's too stupid to strike fear into.

#8 subie94

subie94

    Major Subaru Fan..

  • Members
  • 1,583 posts
  • Epsom,N.H.

Posted 01 April 2005 - 08:07 AM

you gonna paint it to match rest of interior.make sure lights aren't to bright or your prob gonna blind your self.

#9 Caboobaroo

Caboobaroo

    USMB Drunk

  • Members
  • 6,861 posts
  • Oregon City

Posted 01 April 2005 - 10:47 AM

yes it will be the same color as the rest of the interior... or the rest of the interior will be the same color as it. I'm still kinda undecided...

#10 subie94

subie94

    Major Subaru Fan..

  • Members
  • 1,583 posts
  • Epsom,N.H.

Posted 01 April 2005 - 11:58 AM

yes it will be the same color as the rest of the interior... or the rest of the interior will be the same color as it. I'm still kinda undecided...



i think replacing or repainting dash an rest of the interior would be easier then painting the pod ;)

i need to pick a guage an pod up so i can keep an eye on the oil pressure,plus i wanna hook up a volt meter to moniter the voltage going to my amp.

#11 Subarutex

Subarutex

    Oldschool Show Queen

  • Moderator
  • 2,533 posts
  • Mountlake Terrace

Posted 01 April 2005 - 03:32 PM

Gauge pods are so 2002.

#12 garner

garner

    Brat Master Flash

  • Members
  • 689 posts
  • Vilas, NC

Posted 01 April 2005 - 05:13 PM

Gauge pods are so 2002.


totally dude, I'm going heads up display from an F-16



actually, I tried to get one of those things to work in the Brat, after several hours f@#%^&g around with the heat gu, I ended up twisting the damn thing into a knot and throwing it across the shop in a fit of rage!!!!

bottom line is, they no worky in gen 1 brat

garner

#13 TheSubaruJunkie

TheSubaruJunkie

    I'M BAAAAAACK!

  • Members
  • 1,921 posts
  • Sacramento

Posted 01 April 2005 - 09:03 PM

I had that idea as well Garner. My friend had a Nissan Maxima with a HUD for its speedo. I dont think it would be too hard if thought out properly. Only thing I havent figured out is how to wire pressure sensors to a Intel Celeron 866 :)

What year did The Fast & The Furious come out? Was that 2002 :lol:

-Brian

#14 archemitis

archemitis

    guy smiley

  • Members
  • 3,554 posts
  • the big minnie

Posted 01 April 2005 - 09:43 PM

pic no worky. i had to hit back, then forward. it happens alot with the usmb... im sure its the ezboard, or whatever were on now

#15 subie94

subie94

    Major Subaru Fan..

  • Members
  • 1,583 posts
  • Epsom,N.H.

Posted 07 September 2005 - 07:33 PM

Posted Image
this is the guage i installed,not hooked up yet.found out i can use the stock sending unit.(good thing cause the one that came with the guage won't fit)

so what guages you gonna put in(whatcha gonna moniter)

#16 Caboobaroo

Caboobaroo

    USMB Drunk

  • Members
  • 6,861 posts
  • Oregon City

Posted 08 September 2005 - 06:11 PM

gauges that I'm going to install will be all Autometer Phantom gauges. In the A-pillar pod, I'm going to have 1. Boost gauge, 2. A/F ratio gauge, and 3. EGT gauge.

I'm also installing some more gauges in the dash and they'll be 1. water temp, 2. oil temp, and 3. oil pressure.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users