Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

- - - - -

Turbo indicator lights are out?


  • Please log in to reply
4 replies to this topic

#1 Guest_Lab guy_*

Guest_Lab guy_*
  • Guests

Posted 02 August 2003 - 11:02 PM

The Turbo indicator lights on my digital dash went out on my GL10 Turbo Wagon. Turbo stills works but the lights never come on. Anyone have any ideas? or have wiring diagram?
Thanks.

#2 Guest_Hondasucks_*

Guest_Hondasucks_*
  • Guests

Posted 02 August 2003 - 11:54 PM

Look on your passenger side strut tower. If it's an 85-86, you will see two round black things with vacuum hoses going to them, and wires as well. One of them is your fuel cut-off, the other is your turbo light on the dash. I forget which is which. If you have an 87 or newer, there will be only one switch, which is your turbo light switch. My guess is either the switch is bad, the vacuum line is bad, somethign came disconnected, or your turbo light is burned out.

#3 Guest_Lab guy_*

Guest_Lab guy_*
  • Guests

Posted 03 August 2003 - 09:43 PM

Andrew,
Thanks for info I found the 2 vacuum switches but I haven't tested them yet. I asume that when their under neg pressure the switches open. Right?

#4 Guest_Hondasucks_*

Guest_Hondasucks_*
  • Guests

Posted 04 August 2003 - 01:51 AM

One of the switches (for the boost light) will close when it sees anything above atmospheric pressure (I.e., boost), the othe rone will close at 9.5 PSI to cut the fuel off.

#5 Guest_calebz_*

Guest_calebz_*
  • Guests

Posted 04 August 2003 - 08:58 AM

I only have the switch for the light in my 87.. does that mean no fuel cutoff for me?... will have to turn up the boost and find out:evil:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users