Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

My blower motor....


  • Please log in to reply
2 replies to this topic

#1 blaster88

blaster88

    USMB Regular

  • Members
  • PipPipPip
  • 36 posts
  • Reston, VA

Posted 03 April 2005 - 10:32 PM

No, I didn't supercharge my RX.

My heater fan blower was making an awful racket, shaking the whole car at highest speed and I wasn't getting any airflow. So I figured it was going bad, and that I needed to replace it.

I got a great deal on one from Hattori Hanzo who pulled it from a wagon he was parting out, and shipped it right away. Pulled the old one and found this:

Posted Image

A bunch of leaves and straw and stuff - and yes, it is off balance by a lot. I think it was somebody's nest.

Anyway, dumped it out, pulled what I could out of the vent, and put it back in. Quiet and good airflow.

So now I need to put this other blower motor up for sale, I guess....

#2 85Sub4WD

85Sub4WD

    EA82 Junkie

  • Members
  • 1,244 posts
  • Raleigh NC/Charlotte NC

Posted 03 April 2005 - 10:45 PM

Did same thing with mine about 2-3 years ago - found same stuff - I think there was actually a TSB on some sort of rodent problems in the A/C system - don't know for sure though, but I think I saw something listed on alldata.com - glad you fixed it!

#3 WoodsWagon

WoodsWagon

    Formerly 91Loyale

  • Members
  • 3,948 posts
  • NH

Posted 03 April 2005 - 10:55 PM

Your lucky it was just leaves. That fan can butcher mice and then you get to empty the bloody remains out. The rodents seem to get in through the air inlet below the windshield. If you take off the plastic grill under the wipers, you can glue some mesh over the inlet holes and it seems to discourage them.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users