Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Question for the TD04 people


  • Please log in to reply
11 replies to this topic

#1 calebz

calebz

    Andys Coupe killed my cat

  • Administrator
  • 7,547 posts
  • Tacoma

Posted 10 May 2005 - 09:51 AM

As many of you know, I am running a TD04 on a 9.0:1 EA82.

I had heard that the stock wastegate on the TD04 was set to 7-8 PSI

But for some reason I am only seeing 5-6.. No boost leaks that I can see/hear

Also, vacuum is right around 18 in/hg at idle

Does this sound normal or do I need to step up my search for leaks?

#2 Blue84Hatch

Blue84Hatch

    USMB is life!

  • Members
  • 165 posts
  • Farmington

Posted 10 May 2005 - 11:47 AM

If your exhaust is still the small diameter original exhaust it could limit you from building proper boost. Do you have a boost controller and are you using the stock ECU for a turbo EA82. How you have your turbo set up is really important. Please give more info on the setup you have.

#3 calebz

calebz

    Andys Coupe killed my cat

  • Administrator
  • 7,547 posts
  • Tacoma

Posted 10 May 2005 - 12:41 PM

Current exhaust is stock WRX downpipe.. thats it


No boost controller on there right now. Operating strictly on the wastegate. Even the stock EA82 wastegate solenoid has been removed.

The 5-6 psi that its currently boosting to is nice and steady, no spikes or fluctuations. Will probably pop the MBC on there this evening to see what happens.

I am a little concerned about the vacuum levels as well.. After a little readin it seems that most people here are in the 20-22 in/hg range, whereas mine sits steadily at 18.. That could be a timing issue though. Will explore that later.

#4 garner

garner

    Brat Master Flash

  • Members
  • 689 posts
  • Vilas, NC

Posted 10 May 2005 - 12:53 PM

Current exhaust is stock WRX downpipe.. thats it


Ah yeah, I remember that sound, pretty freakin tough sounding eh.....if not a little obnoxious.....

I have a GFB MBC in line but its turned all the way down. I boost to 7-8 psi just like you stated is stock wastegate setting....

Is the wastegate getting signal off the output of the turbo or somewhere else?

I can't comment on the vacuum deal as Delta cams really seem to through vacuum off....


garner

#5 NorthWet

NorthWet

    Eeyore Incarnate

  • Members
  • 5,039 posts
  • Bremerton, WA

Posted 10 May 2005 - 12:55 PM

...
I am a little concerned about the vacuum levels as well.. After a little readin it seems that most people here are in the 20-22 in/hg range, whereas mine sits steadily at 18.. That could be a timing issue though. Will explore that later.

I was thinking that the idle vacuum reading was rather low, too. I seem to remember 22-24 on the last car that I had a vacuum guage on. 18 in of Hg sounds like something you would see on a car with a lot of valve overlap (aftermarket cams?) or some other significant issue. Is the idle vacuum reading fairly steady, of does the needle bounce around or vary? What kind of max vacuum are you showing on overrun/engine braking?

#6 calebz

calebz

    Andys Coupe killed my cat

  • Administrator
  • 7,547 posts
  • Tacoma

Posted 10 May 2005 - 01:26 PM

Ah yeah, I remember that sound, pretty freakin tough sounding eh.....if not a little obnoxious.....
Is the wastegate getting signal off the output of the turbo or somewhere else?
garner


Its a bit on the noisy side.. A bit obnoxious too:-p

Sorry, neglected to mention, the wastegate is getting signal straight from the turbo output. Boost is not fluttering or falling.. sticks right at 5-6 psi

I was thinking that the idle vacuum reading was rather low, too. I seem to remember 22-24 on the last car that I had a vacuum guage on. 18 in of Hg sounds like something you would see on a car with a lot of valve overlap (aftermarket cams?) or some other significant issue. Is the idle vacuum reading fairly steady, of does the needle bounce around or vary? What kind of max vacuum are you showing on overrun/engine braking?



No aftermarket cams. Idle vacuum is rock steady at 18 inches. Didn't really pay attention to what the max was. I know it was quite a bit higher. I will throw a guess out at 26 inches or so. Will have to drive it again and check.

#7 Subarutex

Subarutex

    Oldschool Show Queen

  • Moderator
  • 2,551 posts
  • Mountlake Terrace

Posted 10 May 2005 - 01:53 PM

6 PSI sounds fine. I remember seeing 7ish on mine with just the wastegate.

18 sounds decent. Stock I used to pull 20ish, with the delta cams I have like... zero :lol: ... Ok, not that bad, but its pretty low.

#8 calebz

calebz

    Andys Coupe killed my cat

  • Administrator
  • 7,547 posts
  • Tacoma

Posted 10 May 2005 - 02:18 PM

6 PSI sounds fine. I remember seeing 7ish on mine with just the wastegate.


Well, just for the hell of it I hooked up the MBC and turned it all the way down the where I could hear the ball rattling inside. The tightened it just to the point to where I couldn't hear it rattle. That put me at 8-9psi. Think thats a bad thing with the TD04 and the 9.0:1 compression?

The car seems to like it:-p

#9 garner

garner

    Brat Master Flash

  • Members
  • 689 posts
  • Vilas, NC

Posted 10 May 2005 - 02:30 PM

Think thats a bad thing with the TD04 and the 9.0:1 compression?


No, Thats a very good thing!!!...









for a while anyway.....:headbang:

Actually, I'd love to know what the limit is. If you find out do let us know....I'd probably wait to turn the boost up until I got a few more miles on the break in (this is a new rebuild right?)

btw your wagon is looking pretty pimp these days not quite subaru_styles but atleast your's runs :lol:

garner

#10 subaru_styles

subaru_styles

    the 1st RX wagon!

  • Members
  • 1,696 posts
  • OMGhi2U in da couve

Posted 10 May 2005 - 02:48 PM

hey now, my car runs and starts everytime.....its just has no power due to teh sheetty turbo:banghead: :lol:

#11 Caboobaroo

Caboobaroo

    USMB Drunk

  • Members
  • 7,157 posts
  • Oregon City

Posted 11 May 2005 - 01:41 AM

hey now, my car runs and starts everytime.....its just has no power due to teh sheetty turbo:banghead: :lol:


Mine doesn't even start!:rolleyes: But it does have a TD04 on it... just waiting for the clutch from Will and she'll be runnin in a matter of a few days:D

#12 Steveman09

Steveman09

    Subaru Fanatic!

  • Members
  • 420 posts
  • Portland

Posted 17 May 2005 - 11:58 PM

18hg of vacuum at idle is within specs.

The book says there should be 17hg at idle or more.


Dont feel bad My Vacuum at idle after the rebuild and ported heads is around 10-11hg :)


When I start it up the idle is aggressive and rough, its gets people's attention, I just yell out "its a *************** having these big race cams" LOL

They just look at the car for awhile and smile. HAHA.

BTW Running TD04@higher than 7psi I would not recommend with Stock Engine Managment due to the fact that our ECU's are the weakest link with the EA82T's Longevity and Performance.


BTW Can you guys post some pics of your TD04 installs? I need ideas since I have the turbo and everything, I just need pictures to see how you guys went about it to get a better idea what I need to buy.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users