Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

ej2.2 blown??nope broken waterpump


  • Please log in to reply
2 replies to this topic

#1 scrapdaddytatum

scrapdaddytatum

    the subaru surgeon

  • Members
  • 790 posts
  • charlottesville, virginia

Posted 06 September 2003 - 05:09 PM

so a little info for yall...
i recently thought i had blown my 2.2 in my 95 imprezza
but it was not blown, the idler pulley that bolts to the water pump
sheared off cousing the timing belt to come off. so the following was broken in process, the water pump, the timing belt, the belt tensioner, and 2 idler pullies were worn and loose, oh yeah the front timing covers were trashed. how any of this occured is beyond me. i have never seen this before. but thought you guys might find it interesting.

#2 frag

frag

    Soob shade tree mechanic

  • Members
  • 1,777 posts
  • Montréal, Québec, Can.

Posted 08 September 2003 - 12:41 PM

In all probablility, your water pump seized and caused all the damage you described.
Wise thing it seems to replace the pump when replacing the timing belt or at the very least at the second belt change.,

#3 scrapdaddytatum

scrapdaddytatum

    the subaru surgeon

  • Members
  • 790 posts
  • charlottesville, virginia

Posted 08 September 2003 - 02:26 PM

in fact it was only 12k old along with the timing belt
and it was not seized, looks to be a manufacturing flaw.
just split apart on a casting line




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users