Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

How frustated can I get ????????


  • Please log in to reply
4 replies to this topic

#1 Twowagons

Twowagons

    Eat, Live, Breath Subaru

  • Members
  • 324 posts
  • Montgomery

Posted 15 May 2005 - 11:06 AM

I am about to lose it with my new 80 Brat !!! :banghead: Any advise on the following issues would be sooooo appreciated, either she's getting fixed right or I'm going to make a planter out of her !!
1. rpm's at 4k while warming up and I have to pound the gas pedal to make it go down to 2k rpm's which takes at least 5 minutes then another 5 minutes to get her down to 1200 rpm's , it's cold in Vermont in the winter and I don't want to sit out there babysitting .
2. there is a plumbing shut off valve on the heater hose going into the firewall, whats with that???
3.someone put a glasspack (sp) muffler on it that really sounds like sh-t and tailpipe sticks out just in front of drivers side rear tire, very tacky, anyone know where I can get an exhaust sytem for this?
4.steam coming out of drivers side defrost vent, I guess thats a heater core?
5. cold air rushing in from all vents facing driver and pass. car as a/c controls on dash but nothing under the hood.I don't need a/c but would like to fix the air flow problem before next winter.Please someone help before I do something drastic. Trudy

#2 75subie

75subie

    I`m sold on Subaru

  • Members
  • 3,910 posts
  • Walden

Posted 15 May 2005 - 11:12 AM

check the coolant.mine would do the same exact thing before i put a new water pump in it.the idle would take sooooo long to kick down, but now it idles at a steady 900 rpm.

if you do get to frustrated with it, just don`t make it into a planter.i would take it off your hands for ya:brow:
good luck on fixing it, once its running right you will be gad you put the time into it:burnout:
-Jon

#3 SUBARU3

SUBARU3

    Moderator

  • Moderator
  • 2,739 posts
  • Dallas, Ft. Worth, Texas

Posted 15 May 2005 - 02:44 PM

Lot's of questions......phone call would be best. Call me. I can point you in the right direction.

I PMed my #

Todd

#4 Twowagons

Twowagons

    Eat, Live, Breath Subaru

  • Members
  • 324 posts
  • Montgomery

Posted 15 May 2005 - 04:33 PM

Thank you Todd ;)

#5 kingwill

kingwill

    Did I break that?

  • Members
  • 250 posts
  • Sherwood

Posted 16 May 2005 - 07:24 PM

:lol: for a little bit I thought you were discribing my two brats,

I too have the cold air rush into the cab from the vents I have not been able to stop it either. Maybe a big thick sock would do. My 80' brat has this problem, my 81 brat does not, and I think the reason is that there is a big chunk of insulation in there,(looks like a dead hampster) once I remove that I should have the ice cold blast running through the vents too.
If you find the answer to stop this please let me know to.

Also with your exhast same thing with my 81' glass pak and exhast near the rear drivers tire, This weekend I placed some larger tires on and the pipe was rubbing on the tire, I used a crow bar and my foot and bent it, to get it out of the way.

Sorry to here about your troubles, but it is refreshing to know that these problems just don't happen to me.
Good luck




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users