Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo

Hello AUSTIN...


  • Please log in to reply
2 replies to this topic

#1 sparkster58

sparkster58

    1000+ Super USER!

  • Members
  • 1,141 posts
  • Alki-West Seattle

Posted 15 May 2005 - 10:10 PM

any of you guys in MPLS heard from Austin.....did he make it without blowing up> spark

#2 Tcat55371

Tcat55371

    USMB is life!

  • Members
  • 241 posts
  • Princeton, Minnesota

Posted 16 May 2005 - 07:27 AM

LOL, yeah saw the happy couple yesterday and he is on his way back west this morning. :)

#3 Ratty2Austin

Ratty2Austin

    have tools, will fix

  • Members
  • 2,385 posts
  • West Coast USA

Posted 17 May 2005 - 04:40 PM

I'm home now!!!! woooo!!

more details after I sleep.. i am tired!!!

for now..

impreza got 31mpg tops on most of the trip (when it was not raining, worse gas milage in the mtns, and when it was wet/icey)

no problems except the CEL coming on when sitting at idle too long... went away when driving though...




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users