Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

98 impreza issues...help needed


  • Please log in to reply
2 replies to this topic

#1 harpua

harpua

    Subaru Fanatic!

  • Members
  • 442 posts
  • nowhere, USA

Posted 07 September 2003 - 07:41 PM

i have a friend who has a 98 impreza L wagon. This morning she said that she started the car, and let it warm up for about 5 minutes....when she got into the car, the temp was redlining, the check engine light was on, and when she lifted the hood, she said neither of the electric fans where running...

anyone have any idea what happened?

by the way, no fuses were blown.

thanks for you help....

#2 rallynutdon

rallynutdon

    USMB is life!

  • Members
  • 137 posts
  • Reading PA

Posted 08 September 2003 - 12:01 PM

I wouldn't worry so much about the fans as I would what caused it to overheat, and it wasn't the lack of fans unless your outside temperature was over 100 degrees. I've left many Subaru motors idle for long periods of time with the fans not ever running and no overheating. Check the water pump or thermostat.

#3 Subie Gal

Subie Gal

    GC84Ever

  • Members
  • 1,442 posts
  • WA

Posted 13 September 2003 - 10:21 PM

better yet...
get the car to a dealership ----->fast.

classic symptoms of a bad head gasket.
and 98 Impreza's are prone to em.

have em do a hydracarbon test...
i can nearly guarantee it's HG failure :(

good luck
Jamie




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users