Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Finally - motor is in a runs great.


  • Please log in to reply
2 replies to this topic

#1 tscinmd

tscinmd

    USMB is life!

  • Members
  • 131 posts
  • Barton

Posted 20 May 2005 - 10:50 PM

Got the JDM ea71 installed in the 80 DL hatch today - it runs great. Like a brand new car. 4 months of waiting have finally come to an end. I'll post up some pictures when I get them tomorrow.

#2 ShawnW

ShawnW

    Subaru Master Technician

  • Administrator
  • 12,914 posts
  • Denver, Colorado

Posted 20 May 2005 - 11:07 PM

What was 4 months wait? The delivery or just you having time to install? I hope it wasnt the delivery that seems quite rediculous.

#3 tscinmd

tscinmd

    USMB is life!

  • Members
  • 131 posts
  • Barton

Posted 20 May 2005 - 11:17 PM

Just getting the time to get it in. It seems like it took forever. I got home today from work and my fiance's brother had it installed and running for me. A sort of few days early birthday present. I was glad to see it done. now all I have to do is patch the floors up and its as good as gold.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users