Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Help for a Friend in Western CO near UT/NM border


  • Please log in to reply
No replies to this topic

#1 DrKrazy

DrKrazy

    Which one to drive today?

  • Members
  • 935 posts
  • Golden

Posted 04 June 2005 - 12:39 PM

Hey guys,
Just putting out a request to see if there is anyone near Cortez, CO (near the 4 corners) that could drop by a friend's house and help her troubleshoot her 85 4wd Carb'd GL Wagon. I've been trying to do the best I can for her over the phone but it's just not working without being in front of it. Since I'm in the middle of buying a house and moving I don't have the time to make the long trip out there to her. Sounds like it's something simple, or maybe a bad carb..but here is the full story.
This car has been sitting for 3 years after it brokedown with a bad coil I think it was. The carb had just been rebuilt on the car a year before that. Her justy is finally giving up the ghost on her so she is trying to get this car back on the road. She got the coil fixed and proceeded to drive it 3 hours back to her house from where it was stored. It was doing fine till it choked out on her. Ended up finally getting it home but is barely running now. Can get it to start and idle fine most of the time but it will bog out as soon as she tries to drive it. The EGR light is on (and has been for a long time) but her Solenoid broke, is rigged up atm but wouldn't think it would be causing this problem (though she does need another one which I need to grab from a JY for her)
So far she has replaced the coil, plugs, fuel filter, and maybe some other things. It sounds like it's misfiring from over the phone (LOL), so I gave her some things to replace (which she is doing now since there was rust in the cap, she just called me back while I was writing this)..cap, rotor, plug wires...but I think it maybe something to do with the carb/fuel pump since she says she can keep it running while driving by pumping the gas????. I don't want to keep telling her to try this and that...when she really needs to spend her money on replacing seals, belts, and hoses. So anyways just seeing if there is someone out there that can drop by and check it out. I will defintely make it worth your time 12pk or whatever you want. I'm not as familar with the carbed EA82 since I have never owned one, all mine have been FI. Or if you guys have any other suggestions on what it might be throw them at me..
She also has an 2wd EFI Justy that's got a bad CV, and some other problems which is why she wants her wagon back. Plus she has a family to haul around and the justy doesn't fit alot of people easily.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users