Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

windshield washer pump repair


  • Please log in to reply
3 replies to this topic

#1 Rice Burner

Rice Burner

    USMB Regular

  • Members
  • PipPipPip
  • 41 posts
  • morgantown, wv

Posted 15 September 2003 - 07:37 PM

Hey everyone, I own a 97 impreza o/b sport. Today I attempted to wash the dirt off my windshield with no results. I have fluid that will go to the rear but I dont even hear the front pump. My question is, what is involved with replacing the washer pump and how much time does it take. I most likely will buy the part from NAPA or Advanced Auto Parts to save money unless the Subaru part is comparible in price.
thanks, allen :dead:

#2 gbhrps

gbhrps

    User Awaiting Email Confirmation

  • Members
  • 824 posts
  • canada

Posted 15 September 2003 - 09:01 PM

I had a similar problem on my 97 OB and it turned out to be the wiring connector to the front pump. Pull it and check to see if there is a lot of green slime, etc. If its corroded, some spray electrical contact cleaner ( Radio Shack, NAPA, Autozone) on the connector and on the plug. It may resurrect trhe ailing pump motor, and save you some money.

#3 North Ursalia

North Ursalia

    aka Captain Morgan

  • Members
  • 253 posts
  • Margaritaville

Posted 15 September 2003 - 09:14 PM

The Subaru pump is dirt cheap. I would however suggest you pull your washer nozzles off and try hitting the spray button- the nozzles clog fairly easily, especially if you mix your washer fluid with water and have hard water in your area.

#4 Tiny Clark

Tiny Clark

    Certified Subaru Nut

  • Members
  • 807 posts
  • Germany

Posted 16 September 2003 - 12:05 AM

Have you even looked at the pump to find out where it is or checked the connector? Maybe you should do that first, get an idea of where the parts are, then ask questions.

I'm not trying to be hard on you, but when these kind of questions are asked, I get the feeling the person asking them is not mekanikally inklined.

But, go for it and you'll get a lot of personal satisfaction out of it.

You might want to get a test light to make sure 12 volts is getting to the pump. A lot cheaper than a meter, and sometimes more handy!

Tiny




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users