Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Ignition timing


  • Please log in to reply
3 replies to this topic

#1 saeble

saeble

    New User

  • Members
  • PipPip
  • 23 posts
  • Adelaide South Australia

Posted 24 July 2005 - 12:08 PM

I went to check the ignition timing on my 82 Gl wagon(EA-81). I hook up the timing light and then open the Haynes manual...

paraphrasing... "Look at the sticker under the hood for the correct timing figures"

Some bastige has repainted my car at some point and very thoughtfully removed any signs of a sticker under the hood on my car. Hence I have no idea what degrees from TDC +/- I might need and at what revs/idlespeed this needs to be.

Right now the car is dieseling, running quite hot, backfiring, refusing to idle at a reasonably low RPM, and just generally seeming to be telling me it's out of whack in the iginition dept. If my guesstimates are wrong I'm more than happy to hear anyone elses. I just thought the timing was a good place to start

What idle speed and timing setting do I need ??

cheers in anticipation ! :)

#2 Indrid cold

Indrid cold

    Subaru Nut

  • Members
  • 768 posts
  • Kennewick, WA

Posted 24 July 2005 - 02:15 PM

My sons 84 Brat with EA-81 engine is 8 deg. BTDC. Idle speed I think was 600-700

I will have too look at the other stuff when I get a chance. I hope this will give you some info at least....

#3 saeble

saeble

    New User

  • Members
  • PipPip
  • 23 posts
  • Adelaide South Australia

Posted 24 July 2005 - 10:46 PM

thats a start... thanks !

#4 saeble

saeble

    New User

  • Members
  • PipPip
  • 23 posts
  • Adelaide South Australia

Posted 24 July 2005 - 11:31 PM

went out and adjusted it and yes... huge difference. I haven't had it that long and it seems that someone negelected to tighten the dizzy adjustment bolt, or its worked itself loose in the last few weeks, which would make sense, because it got steadily worse.

for the record I had 10 deg ATDC.... suffice to say that probably fixed all the ills previously mentioned, though I'm still looking for more reasons just in case. I've had too much experience with cars that have been 'fixed' by shadetree mechanics in the past.... the things people do to cars ! :)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users