Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Let The Carnage and Mayham Begin...


  • Please log in to reply
5 replies to this topic

#1 xoomer

xoomer

    1000+ Super USER!

  • Members
  • 1,139 posts
  • Burien, WA

Posted 01 August 2005 - 01:50 AM

Well

Last night I started working on the drivers side Head... (much easier than Passenger) and discovered my problem... Head Gasket Non Existant,... all worn out worst one I have ever seen.... the rings were still intact but the actuall gasket was not... Holy Cow...!

anyhow about half way through I lost my shop lamp... it commited suicide... it fell and the bulb exploded!! I emptied the A/C whoops... and I lost a rocker cover bolt... and bent my torque wrench...

all is well that ends well... hope fully I will have this car back up and running by Saturday...

Xoomer

#2 SakoTGrimes

SakoTGrimes

    Aint got no Subaru!

  • Members
  • 943 posts
  • Grants Pass

Posted 01 August 2005 - 02:22 AM

Those shop lamps (yours was an orange plastic one with a cage I presume?) are the devil. I've dropped one from literally a few inches with a brand new bulb and it popped. Major design flaw or something.

#3 tizzle

tizzle

    Subaru Nut

  • Members
  • 607 posts
  • Bellingham

Posted 01 August 2005 - 04:19 AM

Sounds like a normal working-on-car experience to me. Good luck.

#4 xoomer

xoomer

    1000+ Super USER!

  • Members
  • 1,139 posts
  • Burien, WA

Posted 01 August 2005 - 05:10 AM

no... actually it was of the broken Lava lamp type of shop lamp... good metal frame... recessed bulb... long cord... dropped hundreds of times... and survived and this fall was only a few feet and it died...


boob.. whoops BOOM... spark... glass in eyes... SH** (shows were my mind is)

Xoomer

#5 rcoaster

rcoaster

    H6 Power!

  • Members
  • 502 posts
  • Rochester, NY

Posted 01 August 2005 - 07:09 AM

...tune in tommorow when Xoomer accidentally bumps the hood prop and it looses its hold! :lol:

You should have someone get it on tape and you'll make a killing on selling the DVD's.... :D

#6 xoomer

xoomer

    1000+ Super USER!

  • Members
  • 1,139 posts
  • Burien, WA

Posted 02 August 2005 - 01:40 AM

...tune in tommorow when Xoomer accidentally bumps the hood prop and it looses its hold! :lol:

You should have someone get it on tape and you'll make a killing on selling the DVD's.... :D



to Late.. did that already this morning....




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users