Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Water Leaking from Waterpump Tube 90 Loyale


  • Please log in to reply
3 replies to this topic

#1 sregor13

sregor13

    Eat, Live, Breath Subaru

  • Members
  • 345 posts
  • Lander

Posted 12 August 2005 - 12:04 PM

I just replaced my Water Pump and Water appears to be gushing from the Tube that comes out the side. I did replace the O-ring but it almost looks like the leak is coming from the metal itself. To the right of the metal lip just outside of where the tube goes into the Water Pump. Does anyone here have a recommendation for fixing this. Should I try to replace that metal tube or is there something else I can try? Thanks

#2 hooziewhatsit

hooziewhatsit

    I fix old cars

  • Members
  • 1,333 posts
  • Klamath Falls

Posted 12 August 2005 - 01:30 PM

is it possible that the tube isn't sitting centered in the water pump? could it just need 'tweaked' to get a better seal?

#3 sregor13

sregor13

    Eat, Live, Breath Subaru

  • Members
  • 345 posts
  • Lander

Posted 12 August 2005 - 02:16 PM

I took it out and gooped it with some RTV Sealant then reinsterted. I also took out the top two bolts and gobed them with RTV as well. I know it was leaking from the tube but it may also be leaking from the bottom of the water pump. ( I cant see down there) So I hope not.

The other thing is that water started spraying out from the Thermostat. Do I need to replace that Gasket. Or is that something that happens when a car overheats? Thanks

#4 sregor13

sregor13

    Eat, Live, Breath Subaru

  • Members
  • 345 posts
  • Lander

Posted 12 August 2005 - 03:14 PM

Coolant leak previously mentioned is now fixed. Starting a new thread about a new coolant leak. Somewhere below the Turbo.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users