Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

My 1st Subi!!


  • Please log in to reply
7 replies to this topic

#1 SUBARU3

SUBARU3

    Moderator

  • Moderator
  • 2,715 posts
  • Dallas, Ft. Worth, Texas

Posted 15 August 2005 - 05:43 PM

Well, I wish I was 16 again!! This is me and my first car. It was a 1975, 1400, DL, automatic. Gosh I loved that car!!! Wish I had it now. Has anyone seen it around??????? LOL. OH where is it now?????

Todd

http://www.ultimates....php?photo=7538

#2 leone

leone

    USMB Regular

  • Members
  • PipPipPip
  • 63 posts
  • PNW

Posted 15 August 2005 - 09:53 PM

Great photo!

Where did you last see it (or sell it)? I don't think we could actually NOT keep an eye out for a '75 on the road!

Did your '75 happen to have the SOA dealer installed air conditioning? Or maybe the dreaded add-on A/C from Lone Star? On the '76, we had to turn off the A/C when passing on the freeway!

Well, I wish I was 16 again!! My first car. It was a 1975, 1400, DL, automatic. Gosh I loved that car!!! Wish I had it now. Has anyone seen it around??????? LOL. OH where is it now?????

Todd

http://www.ultimates....php?photo=7538



#3 SUBARU3

SUBARU3

    Moderator

  • Moderator
  • 2,715 posts
  • Dallas, Ft. Worth, Texas

Posted 15 August 2005 - 11:40 PM

I have not seen the car since I was 17. I'm sure it's crushed by now :slobber: .

It had no AC. All my current ones have the Lone-star system.

Todd

#4 moosens

moosens

    Psychotic Subathusiast

  • Members
  • 1,209 posts
  • Bridgeport CT

Posted 16 August 2005 - 03:23 AM

Oh boy,now I want to go digging and fine what I have from my youth as a Subathusiast.


That sure looks like PA in the background.When are you coming back?:)

#5 Twowagons

Twowagons

    Eat, Live, Breath Subaru

  • Members
  • 324 posts
  • Montgomery

Posted 16 August 2005 - 03:22 PM

Young and innocent??????

#6 SUBARU3

SUBARU3

    Moderator

  • Moderator
  • 2,715 posts
  • Dallas, Ft. Worth, Texas

Posted 16 August 2005 - 05:06 PM

Very innocent!

#7 tailgatewagon

tailgatewagon

    1000+ Super USER!

  • Members
  • 1,058 posts
  • Bozeman, MT

Posted 25 August 2005 - 11:07 PM

anyone have pix of the factory and the lone star ac system, i found a 76 that has ac on it under the glove box there is a little deal that says ac by subaru but the ac comp mount looked hack.....

ps very nice suby. did you ever get the set of decals???

#8 SUBARU3

SUBARU3

    Moderator

  • Moderator
  • 2,715 posts
  • Dallas, Ft. Worth, Texas

Posted 26 August 2005 - 02:58 AM

I don't think any Gen 1 or 2 came with "factory " AC. The systems were all added state-side. I have lone stars in all 4 of my gen 1s. They had 2 compressor options....the Mini York and the Sanden 507. I have both.

Did you need pics of anything in particular?

Todd




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users