Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

EA71 experts, what can cause exessive CO2 Emissions?


  • Please log in to reply
34 replies to this topic

#26 Seahag1978

Seahag1978

    1000+ Super USER!

  • Members
  • 1,387 posts
  • Witch City

Posted 27 August 2005 - 09:44 PM

Do yourselves a favor... get a carb from Roo-Builders... they are dirt cheap, and be done with the no idle, stalling, and other headaches.

Car ran like crap... deemed the carb was toast by Mudrat on the phone and "The Mad Scientist", hands on in person, from the NASIOC (NESIOC).

We installed a new Roo-Builders carb, plug n' play, (just had to adjust the float).

I was surprised to find that my engine was junk once I actually got the proper fuel to it... quick compression test and found it... real fast! Changed out the engine with one with 49,000 on it.

We nixed the points and added an electronic distributor... she runs like a champ! Fires right up and stays running until I decide to shut it off! Woohoo!

#27 Kostamojen

Kostamojen

    From FF-1 to BRZ!

  • Members
  • 1,692 posts
  • Roseville, CA

Posted 27 August 2005 - 09:59 PM

I also added some pics to my wagon photo collection showing my progress:

http://community.webshots.com/album/166896604vSrMWC (2nd page)


#28 Seahag1978

Seahag1978

    1000+ Super USER!

  • Members
  • 1,387 posts
  • Witch City

Posted 27 August 2005 - 10:14 PM

I also added some pics to my wagon photo collection showing my progress:

http://community.webshots.com/album/166896604vSrMWC (2nd page)



Yikes! You changed the distinctive tourquoise blue to yellow??? That's just wrong in my book. Mine's red and yellow but I would never even consider changing the dome covers or air cleaner canister to any other color than the tourquoise. Other than that, way to go! Best of luck!

#29 Kostamojen

Kostamojen

    From FF-1 to BRZ!

  • Members
  • 1,692 posts
  • Roseville, CA

Posted 27 August 2005 - 10:33 PM

Yikes! You changed the distinctive tourquoise blue to yellow??? That's just wrong in my book. Mine's red and yellow but I would never even consider changing the dome covers or air cleaner canister to any other color than the tourquoise. Other than that, way to go! Best of luck!

Tourquoise is an aweful color! :P Besides, they needed painting, and im going for a Yellow/Black/Blue look, perhaps with rally decals and such later on. Although If I end up spending my paint money on the carb (I was going to Maaco it that blue color like on the front, because the spray-painting turned out so crappy) I might just go with a flat black mad max look...

#30 Kostamojen

Kostamojen

    From FF-1 to BRZ!

  • Members
  • 1,692 posts
  • Roseville, CA

Posted 29 August 2005 - 08:15 PM

No responce yet from roo builders...

Does anyone have a spare throttle assembly that isnt degraded around the idle screw hole?

#31 Kostamojen

Kostamojen

    From FF-1 to BRZ!

  • Members
  • 1,692 posts
  • Roseville, CA

Posted 03 September 2005 - 06:14 PM

Theres a 70's DL wagon at the JY with an automatic... Will that carb be ok to use?

#32 SUBARU3

SUBARU3

    Moderator

  • Moderator
  • 2,734 posts
  • Dallas, Ft. Worth, Texas

Posted 03 September 2005 - 11:42 PM

Yes

#33 SUBARU3

SUBARU3

    Moderator

  • Moderator
  • 2,734 posts
  • Dallas, Ft. Worth, Texas

Posted 03 September 2005 - 11:43 PM

Theres a 70's DL wagon at the JY with an automatic... Will that carb be ok to use?


Yes

#34 Kostamojen

Kostamojen

    From FF-1 to BRZ!

  • Members
  • 1,692 posts
  • Roseville, CA

Posted 04 September 2005 - 05:06 PM

Alright, well I pulled a carb from a 77 wagon at pick n pull I found... And now its running and running quite well :) I definatly think the throttle/idle screw had something to do with it, because now its adjusting properly and idles VERY low :D

I should have it smoged shortly!

#35 Kostamojen

Kostamojen

    From FF-1 to BRZ!

  • Members
  • 1,692 posts
  • Roseville, CA

Posted 07 September 2005 - 12:15 AM

Well the car runs pretty well now minus one thing.

When I start the car up for the first time after awhile, other than the fact it doesnt idle right away as I left it last night (IE I usually have to turn up the fuel mixture or the idle screw), if I throttle it more than just a tad it will temporarily loose RPMs (via watching the tach) and sound like it wants to die but then it picks back up and revs.
Its pretty annoying, and does get better with more driving.

However I had the air cleaner top off checking to see if it was spraying fuel when I was doing this (and I think it is) and I tried to throttle it hard once, which cause a nice spark and rather nice mini-boom in my face... That wasnt fun. I looked again (from farther away) and noticed a small spark around the fuel jet when giving it gas... Then one more, time from inside the car, I gave it 100% throttle immediatly while it was idling and got a BIG Boom + small fireball from the intake...

Ideas?

And yes this is the brand new, untouched, JUNKYARD carb :P I'm thinking I should put the rebuilt carb back on it, but keep the good throttle and see what that does... However, I saw another post about this kind of problem with an EA motor with a hitachi carb and it was fuel pump/fuel filter related. I do have the OG fuel pump, but It didnt do this before I replaced the carb it had all the other problems and such...




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users